Page MenuHomeSolus

gnome-books and gnome-documents doesn't work "JS ERROR: Error: Requiring Gepub, version none: Typelib file for namespace 'Gepub' (any version) not found"
Closed, ResolvedPublic

Description

Hi,

I've just installed gnome-documents and gnome-books and when I try to run those from menu, nothing happen. When I tried from console I got this errors:

@solus-vm ~ $ gnome-documents 

(org.gnome.Documents:5480): Gjs-WARNING **: JS ERROR: Error: Requiring Gepub, version none: Typelib file for namespace 'Gepub' (any version) not found
@resource:///org/gnome/Documents/js/epubview.js:23
@resource:///org/gnome/Documents/js/documents.js:25
@resource:///org/gnome/Documents/js/search.js:23
@resource:///org/gnome/Documents/js/embed.js:26
@resource:///org/gnome/Documents/js/mainWindow.js:31
@resource:///org/gnome/Documents/js/application.js:38
@resource:///org/gnome/Documents/js/main.js:40
@/usr/bin/gnome-documents:6

JS_EvaluateScript() failed

@solus-vm ~ $ gnome-books 

(org.gnome.Books:5536): Gjs-WARNING **: JS ERROR: Error: Requiring Gepub, version none: Typelib file for namespace 'Gepub' (any version) not found
@resource:///org/gnome/Books/js/epubview.js:23
@resource:///org/gnome/Books/js/documents.js:25
@resource:///org/gnome/Books/js/search.js:23
@resource:///org/gnome/Books/js/embed.js:26
@resource:///org/gnome/Books/js/mainWindow.js:31
@resource:///org/gnome/Books/js/application.js:38
@resource:///org/gnome/Books/js/main.js:40
@/usr/bin/gnome-books:6

JS_EvaluateScript() failed

Programs were installed from command line. When I checked them from Software Center there are marked as uninstalled. I click to install them, message popup about dependencies and button change to "Remove" so marked as installed.

Regards
w

Event Timeline

JoshStrobl triaged this task as Normal priority.Mar 7 2017, 9:35 PM
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
JoshStrobl added a subscriber: JoshStrobl.

Confirmed.

sunnyflunk closed this task as Resolved.EditedMar 7 2017, 9:56 PM
sunnyflunk claimed this task.
sunnyflunk added a subscriber: sunnyflunk.

I have fixed this in unstable so that it will install extra needed packages (needs gjs too) when it's installed https://git.solus-project.com/packages/gnome-documents/commit/?id=46677615bff40f9de47c7791ab813fae4b78cafc

If you install the libgepub package it should resolve your error (which is automatic from next sync). Thanks for the report, it will now be fixed for everyone :)

waltharius added a comment.EditedMar 8 2017, 11:27 AM

Thanks. Now programs starting properly, but no files appears in those programs. I add some documents in Document folder, also I connect my nextclud server to Solus, I've check up "Documents" to being show but, there are no documents in gnome-document program. Sometimes something black blink beneath "Document|Collections" button but nothing more.When I run it from console I got:

@solus-vm ~ $ gnome-documents 

(org.gnome.Documents:3561): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport_from_connection: assertion 'interface_->priv->connections != NULL' failed

Also all buttons in the window are gray and unclicable. When I start gnome-documents from console buttons appears clickable but when I choose something from the menu (like Authors), they starting to be gray.

I just noticed that those blinking thing are notification to restart something, but because they are blinking really fast its hard to noticed what they try to say to me ;)