Page MenuHomeSolus

MATE keyboard preferences -> Layouts -> Options don't work
Closed, WontfixPublic

Description

Hello,

I am not 100% sure this is a Solus issue, but I don't recall having this problem when I tested Linux Mint :

MATE keyboard preferences -> Layouts -> Options don't seem to work (even after a reboot) : I would like to change the behavior of Caps Lock key, but whatever I chose, the behavior remains the default one

Event Timeline

@JoshStrobl are you sure these 2 are similar problems? Here there is only one layout defined so switching (Alt-Shift) is not an issue

@kyrios123 They're both issues in regards to the keyboard preferences in MATE that are likely related or symptoms of a connected issue.

Just a word to confirm this problem does not occurs on Linux Mint 18.1 MATE

ikey reopened this task as Open.Apr 4 2017, 9:55 AM
ikey added a subscriber: ikey.

Reopening because this is separate to T2049 - basic layout switching.

@kyrios123 I need you to test this *after* a full update and reboot on the unstable repo.
I also need you to post the contents of ~/.Xsession-errors when attempting to toggle
this in the UI, so can catch the issue. Thanks.

hello @ikey
nothing appears in ~/.xsession-errors
I'm on unstable, system is up-to-date and the machine was rebooted.

I tried the following :
Options -> Caps Lock key behavior
-> Caps Lock acts as Shift with locking; Shift "pauses" Caps Lock
-> Caps Lock uses internal capitalization; Shift "pauses" Caps Lock

None of them works.
FYI : I do the testing in a VM.

I found out that setting org.mate.desktop.peripherals.keyboard.general.load-extra-items to true solves the problem.
The question is why isn't it updated when keyboard layout options are set ?

@ikey and @Justin when you'll make the next MATE ISO, could you please make sure the default value of the above setting is set to true ?
thanks !

@kyrios123 did this make it into the ISO? If not let me know and I'll assign it to Ikey for the next release.

I don't think it was made.
I was going to make a pull request here for it before ISO creation but I don't know if it is the correct way to proceed.

It's not a big thing but it's probably very easy to fix as I have found the solution.

Is this still an issue?

I haven't done the PR because I don't know if it is the correct way to proceed.
Please let me know, it's a little thing, but nice to have fixed before Solus 4

kyrios123 closed this task as Wontfix.Oct 1 2018, 1:53 PM

I'm going to close this since I know the solution and nobody else complained about this