Page MenuHomeSolus

VLC media player's about dialog has no close (x) button
Closed, ResolvedPublic

Description

When I open VLC media player and go to About to see the version number, there is no x on the popup to close it like in Linux Mint so I have to press Esc.

Edit: I should have mentioned I experienced this on Solus Mate.

Event Timeline

JoshStrobl added a subscriber: JoshStrobl.EditedFeb 14 2017, 4:18 AM

Can't reproduce issue.

Edit: We're thinking it's a WM issue. @feskyde can reproduce.

feskyde added a comment.EditedFeb 14 2017, 4:30 AM

As requested by @JoshStrobl on IRC, I will only say one thing:

OBJECTION!

JoshStrobl triaged this task as High priority.Feb 14 2017, 4:32 AM
JoshStrobl lowered the priority of this task from High to Normal.
JoshStrobl added a project: Software.
JoshStrobl moved this task from Backlog to System and Configuration Fixes on the Software board.
mate-user updated the task description. (Show Details)Feb 14 2017, 1:02 PM

I have the same issue. Also using the MATE edition.

mate-user added a comment.EditedFeb 28 2017, 11:44 PM

This also affects the about dialog for MATE Terminal, Transmission and Disks. Same thing happens for most system apps like Atril, Caja, Calculator etc.

In the comments here, when a comment is edited, it should be possible to click the "Edited" tag beside the time stamp to view edit history. And in comment history view, maybe add some green and red highlighting to show which characters/words were added or removed. Thanks.

@mate-user I fail to see how that is relevant to this issue. And no.

hi @ikey can this be fixed for the next iso snapshot ?

This bug still exists after a fresh install of Solus Mate 2017.04.18.0 and installing all updates and restarting.

algent added a subscriber: algent.EditedAug 30 2019, 1:15 PM

This issue is old, but I see that it is still present.
Just tried this on MATE with VLC 3.0.8 and found that the problem are the themes.

The close button is missing if these themes are used:

  • "Black Mate" and "Black Mate Border".
  • "Green Laguna" and "Green Laguna Border".
  • "Menta" and "Menta Border."

When switching to other theme the close button appears.

JoshStrobl closed this task as Invalid.Aug 30 2019, 1:17 PM

Well none of those themes are the default so not gonna worry about it.

mate-user changed the task status from Invalid to Resolved.Aug 30 2019, 4:10 PM

Looks like it's fixed for me now, thanks!