Page MenuHomeSolus

Steam needs some extra fonts
Closed, ResolvedPublic

Description

These fonts *are* proprietary I believe, so I suggest they are done through the third-party system.

https://support.steampowered.com/downloads/1974-YFKL-4947/SteamFonts.zip

Event Timeline

Does the Steam client not handle the distribution of these?
I've had no issues with Steam fonts.

No. It isn't that obvious, but some in-game popups get cut off pretumaturely because of the font. When you install the fonts, you see the difference.

I think I may have run into the same issue. @DynamicVoid, what exactly do you mean by "cut off prematurely"?

TheBaronHimself added a comment.EditedFeb 8 2017, 8:22 PM

Ah, thanks. I don't think I ran into that issue myself (but then maybe I didn't pay attention to that particular popup; I'm not a Steam power user).

Huh, I just figured that was what it was meant to say >_>
Are there libre alternatives that "just work" ?

I believe that if you create a fake font called "Arial" with the correct width, then it should work. It's mostly the width that seems to be the issue. See https://aur.archlinux.org/packages/fake-ms-fonts/

So couldn't we just add that file in with the Steam package into /usr/share/fonts/conf.d ?

Well, the thing is, the font that replaces it needs to not only be similar to Arial, be almost completely identical to Arial. If you can find a font that provides that, that could be a solution.

After some looking, I propose "Carlito" as a replacement font. I don't know how to make "Arial" reference it however.

aeosynth added a subscriber: aeosynth.EditedFeb 14 2017, 5:46 PM

https://en.wikipedia.org/wiki/Arial#Free_alternatives

Liberation Sans, Chrome OS Core Fonts (Croscore), and FreeSans are metric compatible. @DynamicVoid Carlito (from Croscore) is a replacement for Calibri, which is Microsoft's replacement for Arial.

edit: I would prefer steam to not depend on any font

Here's the same image just with Arial:

aeosynth removed a subscriber: aeosynth.Feb 17 2017, 6:33 PM

Bump, as we have a couple of possible fonts. Liberation Sans or FreeSans are probably the best options. Here's an AUR package that esentially does the exact same thing we're trying to do: https://aur.archlinux.org/packages/fake-ms-fonts/

I would do it, but my bash scripting level is -1. So is my eopkg knowledge level.

Baemir added a subscriber: Baemir.
This comment was removed by JoshStrobl.

@livingsilver94 Removed comment. Please keep your language appropriate.

livingsilver94 added a comment.EditedSep 20 2017, 3:42 PM

I don't see where the problem is since the whole Phabricator needs this kind of moderation but anyway, sorry for that.

I'll repost:
Bump for this. Even Team Fortress 2 text is jagged and bigger than normal.

Edit: ah damn sorry. I used "out" instead of "up". Didn't know "out" was much worse and different. Sorry again.

DataDrake closed this task as Resolved.Jul 29 2018, 6:05 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

AFAIK this is no longer an issue.