Page MenuHomeSolus

Touchpad randomly stops working
Closed, ResolvedPublic

Description

I've seen this on a wide variety of hardware. At some point, perhaps prompted by connecting or disconnecting other devices (the mouse?), the touchpad stops responding. Only a reboot will fix it. It's as though it gets stuck in the middle of a transaction or something. No clue.

Event Timeline

Update: I booted with the mouse plugged in, and never removed it. Just before doing so, I tested the touchpad, and it was dead. Maybe this is because I happened to boot up with the lid closed, as I was on external HDMI? I think it's safe to say at this point that this is easily reproduced within a workday. Locking and unlocking the screen a few times may be necessary. Perhaps there's a way to always make it happen, but I haven't had time to test it in a directed manner.

DataDrake edited projects, added Hardware; removed Triage Team.Feb 22 2017, 8:39 PM

I confirmed that the mouse cursor can still be moved by using the touchscreen, and the keyboard still works, so this is definitely a touchpad issue. Plugging in an external mouse works fine too.

JoshStrobl moved this task from Backlog to Other on the Hardware board.Oct 26 2017, 2:52 AM
JoshStrobl added a subscriber: JoshStrobl.

Does this issue still persist under a fully upgraded Solus 3?

JoshStrobl moved this task from Other to Input on the Hardware board.Oct 26 2017, 2:52 AM
JoshStrobl closed this task as Resolved.Nov 19 2017, 1:10 AM
JoshStrobl claimed this task.

Closing due to lack of response.