Page MenuHomeSolus

ChefDK
Closed, WontfixPublic

Description

Name: ChefDK
Homepage: https://www.chef.io/chef/
Why should this be included in the repository? Chef is used by DevOps Community and its nice have to it in Solus as well as.

Is it Open Source (yes/no): Yes

How many users do you anticipate will use this software?: All DevOps Users
Link to source tarball/zip file: https://github.com/chef/chef-dk/archive/v1.2.11.zip

DataDrake triaged this task as Normal priority.

Any progress on this? I specifically would like version 1.2.20. 1.2.22 has a has a critical bug with vagrant-berkshelf.

https://github.com/chef/chef-dk/archive/v1.2.20.zip

Is the the gem package manager available on Solus? Otherwise that seems like a prereq to installing this package possibly. Seems to require a lot of gems (ruby packages) that I'm not sure are packaged for Solus

Needs ruby >= 2.3 current version in the repos is 2.2.6

Repos now contain Ruby 2.3.4, but I'm not sure how to handle the packaging. There are ruby gems, the package is build with omnibus... maybe someone with more experience can check this.
@Justin can you move it back to Accepted for Inclusion?

Hi just wanted to add a meager 2c to this. I ended up extracting the RHEL7 RPM contents into /opt/chefdk and running the script from POST to create the relevant symlinks for the binaries and that was that. The chef tools themselves use their own ruby in /opt/chefdk/embedded and everything just works.

Not sure if this is at all useful for building a solus package (probably not) but it's a workaround for now.

grego9 added a subscriber: grego9.Nov 10 2017, 2:17 PM

Hi just wanted to add a meager 2c to this. I ended up extracting the RHEL7 RPM contents into /opt/chefdk and running the script from POST to create the relevant symlinks for the binaries and that was that. The chef tools themselves use their own ruby in /opt/chefdk/embedded and everything just works.

Not sure if this is at all useful for building a solus package (probably not) but it's a workaround for now.

Thank you! I used de debian package and worked too. Hope they add this to the repo

running the script from POST to create the relevant symlinks for the binaries and that was that

What exactly do you mean by that?

running the script from POST to create the relevant symlinks for the binaries and that was that

What exactly do you mean by that?

Download de .deb or .rpm packages, uncompress it. Move the content to /opt. You'll find a "postinst.sh" script. Run it as root, that will create de syslinks to the chefdk binaries. The deb package worked for me.

@JosephMart As @grego9 said, but if you struggle I've attached the script as I extracted and used it.

Ok, so looking at this, I don't think it's really possible to create a package from the script, which means to provide the package, would be providing all the gem packages and running it via whatever ruby version the system is on.

Doing it in such a way doesn't appear to be recommended by the chek-dk people.

Interesting...

yacn added a subscriber: yacn.EditedAug 14 2018, 12:05 PM

@sunnyflunk I need this for work so I took a crack. I think I was successful (it's working for me in my daily use so far) in packaging chefdk by repackaging the Debian package via a package.yml. Source for the file as well as a pre-built eopkg are both located here https://github.com/yacn/chefdk-eopkg

I did package this at one point, it did not take long. The issue is more around support. It felt like a self build version would not be supported upstream. It would also really need a user to manage it as I won't be testing it.

Being able to test the gem packages would also be a plus, but I haven't a clue how the ruby system works (but packages generally come with tests).

DataDrake closed this task as Wontfix.Oct 20 2018, 3:58 PM
DataDrake added a subscriber: DataDrake.

Closing due to lack of activity in over 30 days. Still eligible for inclusion.