Page MenuHomeSolus

IntelliJ IDEA Community Edition
Closed, WontfixPublic

Description

IntelliJ IDEA Community Edition
Open Source: yes, Apache 2.0
website: https://www.jetbrains.com/idea/
tarball: https://download.jetbrains.com/idea/ideaIC-2016.2.1.tar.gz

Related Objects

StatusAssignedTask
WontfixJoshStrobl
ResolvedDataDrake
ResolvedtheSoenke
ResolvedJoshStrobl

Event Timeline

PhnxRbrn created this task.Aug 13 2016, 8:21 PM

Linked tarball is to the compiled version. Actual source code can be found on GitHub:
https://github.com/JetBrains/intellij-community

The releases on GitHub are hard to understand. According to IDEA CE download page, this is the release we want:
https://github.com/JetBrains/intellij-community/archive/idea/162.1447.tar.gz

There appears to be releases for community versions of the other JetBrains IDEs, though some of them don't have community versions available from the main website. Perhaps they could be looked into as well?

CLion: https://github.com/JetBrains/intellij-community/archive/clion/162.1628.20.tar.gz
WebStorm: https://github.com/JetBrains/intellij-community/archive/webstorm/162.1447.27.tar.gz
PHPStorm: https://github.com/JetBrains/intellij-community/archive/phpstorm/162.1121.38.tar.gz
RubyMine: https://github.com/JetBrains/intellij-community/archive/rubymine/162.1447.29.tar.gz
PyCharm: https://github.com/JetBrains/intellij-community/archive/pycharm/162.1628.8.tar.gz

@DataDrake already provides JetBrains IDEs via Third-Party.

We can still build IDEA Community from source. Honestly, it's not too hard to install manually. one tarball to unpack into /opt. run bin/idea.sh. tell it to create the .desktop menu entries. Done.

DataDrake triaged this task as Wishlist priority.Sep 15 2016, 4:36 AM

I've tried to build intellij from source. The problem is it needs javafx as a dependency (now OpenJFX). And OpenJFX seems not to provide release tarballs. Only a mercurial repo https://wiki.openjdk.java.net/display/OpenJFX/Main

DataDrake closed subtask T838: OpenJFX as Resolved.Feb 22 2017, 8:08 PM

In the software center I can only find the ultimate edition, can't find the Community Edition. Is this expected?

tristan957 added a subscriber: tristan957.EditedJun 7 2017, 4:40 PM

@theSoenke I have found this: http://hg.openjdk.java.net/openjfx/8u60/rt/archive/tip.tar.gz I am not sure if it will be helpful or not.

Edit: It seems like @DataDrake already landed the OpenJFX package a while back if that help you at all

All the subtasks seem to be completed and resolved. What's the holdup if I may ask?

Probably someone attempting to package it

Please think about Clion and Pycharm Community addition too.

you can install and manage any IntelliJ IDE using Toolbox which is officially supported by JetBrains, they provide Appimage so it is easy to install too.
It has other features like Github Integration with browser like Firefox and Chrome, All project are shown in one place, can install EAP version and many more.

renpai added a subscriber: renpai.Jan 19 2018, 7:49 AM

FYI, there's a snap for this.

JoshStrobl closed this task as Wontfix.Jun 25 2018, 12:25 PM
JoshStrobl claimed this task.

This has sat in accepted for inclusion for almost two years now. Clearly, there is a lack of demand for the inclusion of this software, nobody has stepped up to provide a patch, maintain it, and properly integrate it. Closing as a result. Feel free to reopen but only when someone offers a patch via our proper patch submission methods and volunteers to be maintainer.