Page MenuHomeSolus

Gnome Wayland session doesn't source ~/.profile, ~/.bashrc, or indeed /usr/share/defaults/etc/profile
Closed, WontfixPublic

Event Timeline

anaknaga renamed this task from Gnome Wayland session doesn't source ~/.profile, ~.bashrc, or indeed /usr/share/defaults/etc/profile to Gnome Wayland session doesn't source ~/.profile, ~/.bashrc, or indeed /usr/share/defaults/etc/profile.Jan 13 2017, 7:24 PM
anaknaga created this task.

So is this a GNOME Wayland issue or GDM?

JoshStrobl closed this task as Invalid.Mar 19 2017, 6:10 AM
JoshStrobl added a subscriber: JoshStrobl.

Closing due to lack of response.

taaem reopened this task as Open.Oct 10 2018, 10:19 AM
taaem added a subscriber: taaem.

So I'm opening this up again, because its a valid issue.
The issue is that on gnome wayland there is no "main" bash/zsh/... shell from which the xserver is started so the bash profiles aren't read and enviroment variables aren't set.
Upstream fixed this in this commit: https://gitlab.gnome.org/GNOME/gnome-session/commit/7e307f8ddb91db5d4051c4c792519a660ba67f35
This obviously doesn't work on Solus, because there is no /etc/profile but a /usr/share/etc/profile and so the login shell never gets run. I tried to manually fix that and see if it works afterwards, but unfortunally there seems to be another issue somewhere.
The obvious user facing issue this creates is that /snap/bin isn't added to the $PATH and /var/lib/snapd/desktop isn't added to $XDG_DATA_DIRS, so Snaps just don't show up in Gnome. The other issue is that $QT_QPA_PLATFORMTHEME is not set to gtk2, so Qt apps (eg. KeepassXC,...) isn't using *any* styling at all.

@taaem try this out for me.

Edit this file /usr/bin/gnome-session

Change /etc/shells to /usr/share/defaults/etc/shells on line 6 and see if it works

@sunnyflunk did that already but nothing changed, tried it with bash and zsh as my main login shell

taaem added a comment.EditedOct 10 2018, 11:04 AM

The thing is that flatpak is added to path and working fine, because it is in /usr/share/gdm/env.d/... *but* its overwriting the XDG_DATA_DIRS variable there, if you comment that line out flatpak is broken but snaps are there.

DataDrake triaged this task as Low priority.Oct 16 2018, 8:53 PM
JoshStrobl closed this task as Wontfix.Oct 15 2019, 1:32 AM

Closing since Wayland support is not planned at this time and there has been multiple stack upgrades since then.