Page MenuHomeSolus

Timeshift
Closed, WontfixPublic

Description

Name: Timeshift
Homepage: http://www.teejeetech.in/
Open Source: yes
Download: http://www.teejeetech.in/p/timeshift.html

Excellent tool to take snapshot of an entire system with rsync

We can install this app with .run available in download page but missing "cron" is require in the system

-> check in software center the "Dcron" package. After that, Timeshift can start

Newest version I could find of this is February 2014.

JoshStrobl closed this task as Wontfix.Sep 20 2016, 6:35 PM
JoshStrobl claimed this task.
phihos added a subscriber: phihos.Aug 6 2017, 11:27 PM

Now the latest version is v17.2 and it won't run even with dcron installed. The culprit is a reference to an older version of libvte.
For those interested: I wrote a blog post on how to compile it from source.

@baimafeima Thanks for the notification. The installer still does not work because of the same reasons as last time. You can still follow my guide to compile ist yourself though. This time the code fix is not necessary anymore :-)

Kinnal added a subscriber: Kinnal.Feb 3 2018, 10:29 PM
User1 added a subscriber: User1.May 9 2018, 12:10 PM

Hi!
Why will this not be included in the app store? I see no similar program with a user friendly GUI like this one has!

@phihos I created a package.yml for timeshift with the help of your guide. Maybe you could help me with the missing manpage, I have not that much experience with packaging?

krieghof added a comment.EditedJun 2 2018, 8:36 PM

Derp, there are no manpages for timeshift.

For the cron workaround I made a systemd timer, which starts 10 min after boot and then every 60 min.
The timer runs "timeshift --check" and triggers the snapshot if necessary.

There is only one bug, if the systemd timer is triggered and timeshift-gtk is open timeshift --check fails with the error "timeshift is already running"

@JoshStrobl Do you know why timeshift is not working with dcron, maybe we can find a better workaround or fix?

hubris added a subscriber: hubris.Jul 8 2018, 3:47 PM
SolarLiner added a comment.EditedAug 27 2018, 4:25 PM

If you try to open timeshift-gtk while a snapshot is running, you get the same "Timeshift is already running" message. It seems the behavior is not a bug but a feature.
Any update on the status for this package? Timeshift is quite unique as there aren't other system backup tools that work as well as Timeshift. Anything needed for inclusion?

rabj58 added a subscriber: rabj58.Feb 5 2019, 9:08 AM