Page MenuHomeSolus

Tuxguitar
Closed, WontfixPublic

Description

Name: Tuxguitar
Homepage: https://sourceforge.net/projects/tuxguitar/
In the repo there is already musescore but tuxuitar is better for guitarists (and bassists) because it allows you to use tablatures, instead of the traditional style of music writing, even when you want to listen to the song with all the instruments together.
Musescore lets you use the guitar tabs only if you're listening to the guitar part and loses the chance to try out the song with all instruments contained therein.
So if you want to practise with the all instruments you have to learn the sheet music style.
Tuxguitar is released under the GNU Lesser General Public License.
In my opinion everyone will use tuxguitar instead of musescore because is easier to use.
Link to source tarball/zip file: https://sourceforge.net/projects/tuxguitar/files/TuxGuitar/TuxGuitar-1.4/tuxguitar-1.4-src.tar.gz/download

irondave created this task.Jan 11 2017, 1:04 PM

I was going to fill a request for Tuxguitar too, it's the best tablature editor for Linux. I really hope the devs put it in the repo.

DataDrake triaged this task as Wishlist priority.Jan 14 2017, 6:39 PM
DataDrake added a project: Needs Maintainer.

It's on my todo list, I'm in need of a software like that on Solus.

Will try to build it this week.

Clifspeare added a comment.EditedMay 16 2017, 7:03 PM

Good luck. I looked at it but don't have much experience with Maven.

DataDrake closed this task as a duplicate of T4256: Tuxguitar.Aug 20 2017, 5:46 PM
DataDrake reopened this task as Open.Aug 20 2017, 10:51 PM
DataDrake merged a task: T4256: Tuxguitar.
DataDrake added subscribers: eronis, baimafeima.
Taki added a subscriber: Taki.Sep 27 2017, 4:07 PM
joebonrichie added a subscriber: joebonrichie.

I play guitar, I guess I could maintain this ;D

joebonrichie removed joebonrichie as the assignee of this task.Feb 18 2018, 1:33 PM

Any news on including it?

I don't mind doing the initial packaging for this but ideally I would like a maintainer to properly test and keep the software updated.
There are also a lot of sub projects / native modules where the packager will need to decide to add support for them or not

I don't mind doing the initial packaging for this but ideally I would like a maintainer to properly test and keep the software updated.
There are also a lot of sub projects / native modules where the packager will need to decide to add support for them or not

I've been thinking about learning how to package and mantain packages for some time, maybe I could do it once I'm comfortable with the process. For now I'm up to test it if you or someone else do the initial package.

This comment was removed by JoshStrobl.
JoshStrobl closed this task as Wontfix.Jun 25 2018, 12:12 PM
JoshStrobl claimed this task.

This has sat in accepted for inclusion for almost a year now. Clearly, there is a lack of demand for the inclusion of this software, nobody has stepped up to provide a patch, maintain it, and properly integrate it. Closing as a result. Feel free to reopen but only when someone offers a patch via our proper patch submission methods and volunteers to be maintainer.

I remeber vagely I had a look at this some time ago. Isn't it rather a problem of lacking an out of the box working jack package ?

This has sat in accepted for inclusion for almost a year now. Clearly, there is a lack of demand for the inclusion of this software, nobody has stepped up to provide a patch, maintain it, and properly integrate it. Closing as a result. Feel free to reopen but only when someone offers a patch via our proper patch submission methods and volunteers to be maintainer.

August 3, 2018 was an update. Who said that the package is not developing? The more multimedia software in the repositories, the better (especially if there are no analogues), why not include it in the repository?

Nobody said anything about the package not being developed. Re-read what I stated.

Nobody said anything about the package not being developed. Re-read what I stated.

Yes, sorry, not so understood. But really there are no users who need this software? Either no one wants to take for this transfer?

Well, if nobody wants to step up to be the maintainer, that's fine. It's their free time and they're volunteers like the rest of us. You're welcome to step up, provide a patch, and maintain it if it is important to you.