Page MenuHomeSolus

Cannot play Hedgewars - error
Closed, ResolvedPublic

Description

Hi. It's my first bug report, so please forgive me if I mark something incorrectly ;p
I installed Hedgewars, but I can't play it. The app opens, but every time I want to start a game, I see the following error

.
Anyone has experienced the same?

Event Timeline

Didimidi created this task.Jan 9 2017, 4:32 PM

A log while running it via the Terminal might help.

^ here you are

$ hedgewars
[PHYSFS] Init: ok
[PHYSFS] Mounting '/usr/share/hedgewars/Data' to '/': ok
[PHYSFS] Mounting '/home/jakub/.hedgewars/Data' to '/': ok
[PHYSFS] Mounting '/home/jakub/.hedgewars' to '/': ok
[PHYSFS] Setting write dir to '/home/jakub/.hedgewars': ok
Starting Hedgewars 0.9.22-r11265 (4c4f22cc3fa4)
Object::disconnect: Unexpected null parameter
QCoreApplication::postEvent: Unexpected null receiver

I can confirm this. The bug is not pressented in solus 1.2.1 ( with the lastet updates to 31 december 2016 ) but happens in latest snapshot 1.1.2017.

So, my initial guess is that your graphics card/chipset doesn't support a high enough OpenGL version to play the game. Could you guys report back with what GPU your machines have?

Intel HD 3000 integrated graphics

I have intel celeron n2840 with HD graphics ( GPU clock speed 311 MHz
Turbo clock speed 792 MHz) . I can't find what HD graphics model it has.

DataDrake triaged this task as Normal priority.Feb 22 2017, 9:32 PM

Can you all please verify this on the latest updates? I still can't reproduce the error.

DataDrake moved this task from Backlog to Package Fixes on the Software board.Jul 20 2017, 2:50 AM
JoshStrobl closed this task as Resolved.Aug 5 2017, 2:44 AM

Closing due to lack of response.