Page MenuHomeSolus

Green border around text in GIMP
Closed, ResolvedPublic

Description

Okay so when drawing text in gimp on a black background you can clearly see a green outline around it. Its not as noticeable the larger your text gets but the smaller the more obvious. This bug is apparently known and has been noted: https://bugzilla.gnome.org/show_bug.cgi?id=657047
I'll attach a screenshot.

Event Timeline

Riokei created this task.Jan 8 2017, 5:45 PM
macifom added a subscriber: macifom.EditedJan 9 2017, 3:01 AM

The referenced ticket suggests this is most likely the result of fontconfig misconfiguration but I don't see an offending config in ~/.config/fontconfig in my 2017.01.01.0 install.

Riokei added a comment.Jan 9 2017, 3:22 PM

I had to create a font.conf in /etc/gimp/2.0/ just so I can get back to work, still not sure what caused it. I have no offending config either.

Unable to reproduce this issue. Can you confirm whether it still exists on a fully upgraded system or via a fresh install of Solus with a 2017.04.18.0 ISO?

Riokei added a comment.EditedApr 20 2017, 8:26 PM

On my fully upgraded system without that font.conf I still get the issue. I'd test on my laptop but I seem to have a separate issue on that.

Tested on my laptop same issue.

JoshStrobl triaged this task as Normal priority.Nov 25 2017, 2:24 AM
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
macifom removed a subscriber: macifom.Jan 9 2018, 7:24 PM
rjurga added a subscriber: rjurga.Feb 15 2018, 6:23 PM

I have the same issue. The workaround is to create ~/.fonts.conf containing

<fontconfig>
 <match target="font">
  <edit name="rgba" mode="assign">
   <const>none</const>
  </edit>
 </match>
</fontconfig>

Found this solution here.

luzpaz added a subscriber: luzpaz.Apr 22 2019, 12:14 PM

Can this ticket be closed ?

The issue is still present.

rjurga removed a subscriber: rjurga.Nov 16 2019, 10:50 AM

This seems to be finally solved. I cannot reproduce it anymore.

Girtablulu closed this task as Resolved.Nov 18 2019, 6:21 PM
Girtablulu claimed this task.