Page MenuHomeSolus

Plugging in a HDMI monitor or projector crashes X on the nvidia driver
Closed, InvalidPublic

Description

It's 100% replicable with at least 2 distinct projectors and 2 monitors that I have tried.

The solution is to reboot with the hdmi cable in.

This is a piss poor solution that makes me wary to recommend linux to anyone. I understand it might well be nvidia's fault, but still.

Event Timeline

usillos created this task.Jan 3 2017, 11:24 AM

wintermute ~/bin $ inxi -G
Graphics: Card-1: Intel Haswell Integrated Graphics Controller

Card-2: NVIDIA Device 11e1
Display Server: X.Org 1.18.4 driver: nvidia
Resolution: 2560x1440@59.95hz, 1920x1080@60.02hz
GLX Renderer: GeForce GTX 765M/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 375.26
r000d added a subscriber: r000d.Apr 7 2017, 8:42 PM

I have same issue. On ubuntu everything works.

levelast@levelast-thinkpad ~ $ inxi -G
Graphics:  Card-1: Intel Device 5916
           Card-2: NVIDIA GM107M [GeForce GTX 950M]
           Display Server: X.Org 1.18.4 drivers: nvidia FAILED: modesetting
           Resolution: 1920x1080@60.03hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 950M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 381.22
JoshStrobl moved this task from Backlog to Other on the Hardware board.Oct 26 2017, 2:56 AM
JoshStrobl added a subscriber: JoshStrobl.

Does this issue still persist under a fully upgraded Solus 3?

JoshStrobl closed this task as Invalid.Jan 27 2018, 5:29 PM

Closing due to lack of response.