Page MenuHomeSolus

Canon LBP6030-6040-6018L (Wireless Laserprinter) no driver/not working
Closed, DuplicatePublic

Description

My Canon Printer isn't working... and in the driver list i cant see my printer...
and the generic driver isnt working too...

and the driver from the canon website is only working on .deb / apt-get systems....

http://www.bilder-upload.eu/show.php?file=4ac6db-1482677388.png
http://www.bilder-upload.eu/show.php?file=2267c0-1482677281.png

Source: http://gdlp01.c-wss.com/gds/1/0100005951/05/Linux_UFRIILT_PrinterDriver_V130_us-EN.tar.gz

Event Timeline

DataDrake updated the task description. (Show Details)Dec 25 2016, 5:52 PM
DataDrake added a project: Package Requests.

Looks like the driver is licensed under GPL-2.0, so we should be able to package it. The source is distributed alongside the precompiled drivers.

and whats with this list? will it implemented there? http://i.imgur.com/2stRYGC.png

Some of the canon drivers are shipped alongside CUPS and other parts of the printing stuff. That's why some of them are already there. Once I've packaged these drivers, you'll have to install them from the Software Center and then they will be available from the list.

Some of the canon drivers are shipped alongside CUPS and other parts of the printing stuff. That's why some of them are already there. Once I've packaged these drivers, you'll have to install them from the Software Center and then they will be available from the list.

okay thank you <3

I have installed the package "canon-ufriilt-common" but what i have to do now? the driver is not in the list.... or in cups :D

http://i.imgur.com/ycGRI6w.png

so.... what i have to now xD

@TeleSkope21 Need one more package that I'm still sorting out

DataDrake triaged this task as Normal priority.
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.