Page MenuHomeSolus

Firefox crashes or the tabs do
Closed, InvalidPublic

Description

When it crashes:

  • coredumpctl: Fri 2016-12-23 01:48:47 WET 1576 1000 1000 11 * /usr/lib64/firefox/plugin-container
  • sometimes it outputs: In pixman_region_append_non_o: The expression r->x1 < r->x2 was false

When the tabs crash it outputs:

[Parent 1379] WARNING: pipe error (75): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320

###!!! [Parent][MessageChannel] Error: (msgtype=0x2E007D,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

It's worth to mention that e10s is not enabled and I am using default settings (for testing purposes), but it crashes without a user.js and with one as well.

All was fine and dandy until the last firefox update.

Event Timeline

BRM created this task.Dec 23 2016, 1:52 AM
BRM updated the task description. (Show Details)
BRM updated the task description. (Show Details)
BRM updated the task description. (Show Details)Dec 23 2016, 1:55 AM

Can't reproduce issue.

BRM added a comment.Dec 24 2016, 3:42 AM

I would like to add that when firefox's tabs crash (obviously using chromium's ipc channel implementation), so do chrome's. It just happened.

DataDrake closed this task as Invalid.Dec 28 2016, 11:29 PM
DataDrake added a subscriber: DataDrake.

If you've overriden key files like user.js, there's not much I can tell you other than to undo the changes and reinstall Firefox.

BRM added a comment.EditedJan 27 2017, 9:05 PM

@DataDrake You're kidding me, right? It's literally explicitly stated in the OP that I used the default settings for testing purposes. In fact, I have recently reinstalled Solus AND the unmodified liveCD version of Firefox kept crashing just the same.

It happens CONSTANTLY. Does not happen on any other distro. Might have to compile it myself apparently. No big deal but still, it occasionally crashes xorg.

Jan 27 20:59:01 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:01:10 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error (60): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320
Jan 27 21:01:10 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error (63): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320
Jan 27 21:01:10 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error (49): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320
Jan 27 21:01:10 space budgie-panel.desktop[906]: [Parent 1022] WARNING: waitpid failed pid:1249 errno:10: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/base/process_util_posix.cc, line 273
Jan 27 21:01:25 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error (64): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320
Jan 27 21:01:25 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error (49): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320
Jan 27 21:01:25 space budgie-panel.desktop[906]: [Parent 1022] WARNING: waitpid failed pid:11104 errno:10: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/base/process_util_posix.cc, line 273
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error: Broken pipe: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 684
Jan 27 21:05:29 space budgie-panel.desktop[906]: [Parent 1022] WARNING: pipe error (89): Connection reset by peer: file /home/build/YPKG/root/firefox/build/firefox-50.1.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 320

DataDrake reopened this task as Open.Jan 27 2017, 9:14 PM

but it crashes without a user.js and with one as well.

I interpreted that as a non-standard config. If that's not the case, I'm sorry for the confusion.

Which update borked it? Like, eopkg blame.

BRM added a comment.EditedJan 27 2017, 9:32 PM

It's been like this since day 1. It crashes, especially whilst watching videos or when I'm on whatsapp with multiple tabs open. I don't understand why it only happens to me, but I figured reinstalling and not touching xorg.conf would maybe fix it, but no, the liveCD version crashed just the same, which is odd considering it works just fine on gentoo.

i5-4670, r9 280x, no special conf files (not anymore, that is).

Name: firefox, version: 50.1.0, release: 83
Package Maintainer: Peter O?Connor <peter@solus-project.com>
Release Updater: Peter O?Connor <peter@solus-project.com>
Update Date: 2017-01-12
Revert optimizations as can still crash
Still crashing on more media rich websites

So Peter is aware of it. Oh.

OK lets start this again. So does the current Firefox build you have installed flake out in its vanilla state? Also comparing distros here is sorta inconsequential as we build things differently. :)

BRM added a comment.EditedJan 27 2017, 9:45 PM

@ikey Yes, it crashes in its vanilla state on media rich websites and those are the errors I get.
Oh and I mentioned that as a justification as to why I'm posting it here as opposed to mozilla's own bug tracker.

BRM added a comment.Jan 28 2017, 7:02 PM

@ikey Even the official binary crashed the exact same way as when a tab crashes.
Oh yeah, apparently this wasn't always an issue for me. You need to find out what version of Firefox Solus was using on the 23rd of December because the previous build was working flawlessly for me.

BRM closed this task as Invalid.Apr 10 2017, 12:39 AM

Likely to do with my dying HDD. Will edit this once I get a new storage device.

Unsure why but I'm not getting notifications on this issue, really sorry. Manually went digging back in to find this.
Any chance you'd be able to test an unstable ISO to see if the problem prevails - post HDD Upgrade?

BRM added a comment.Apr 10 2017, 1:06 AM

Definitely. What differences would there be?

BRM added a comment.Apr 10 2017, 5:31 PM

@ikey I've got my ssd. Any chance you could post the link to the ISO?