Page MenuHomeSolus

Lutris doesn't start
Closed, ResolvedPublic

Description

I tried to install lutris from the repo, but it doesn't start.
Running it via terminal gives me the following output:

lutris
Traceback (most recent call last):

File "/usr/bin/lutris", line 50, in <module>
  from lutris.gui.installgamedialog import InstallerDialog
File "/usr/lib/python3.5/site-packages/lutris/gui/installgamedialog.py", line 9, in <module>
  from lutris.installer import interpreter
File "/usr/lib/python3.5/site-packages/lutris/installer/interpreter.py", line 15, in <module>
  from lutris.util.steam import get_app_state_log
File "/usr/lib/python3.5/site-packages/lutris/util/steam.py", line 6, in <module>
  import pyinotify
File "/usr/lib/python3.5/site-packages/pyinotify.py", line 176
  except IOError, err:
                ^

SyntaxError: invalid syntax

Can anyone reproduce this?
Thanks

Event Timeline

Try installing python-inotify

fluffymadness added a comment.EditedDec 25 2016, 10:43 PM

It is already installed on my system. I reinstalled it and tried again, but it still has the same error.

JoshStrobl changed the task status from Open to In Progress.Dec 26 2016, 9:49 PM
JoshStrobl claimed this task.
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
JoshStrobl closed this task as Resolved.Dec 26 2016, 10:12 PM

Turns out it was a missing cpython file for python-notify. This was resolved in unstable as of https://git.solus-project.com/packages/python-inotify/commit/?id=67b369f08a75a8762559b13a9837c0c31ff865ef

Regardless, I fixed up the build for Lutris, updated it to 0.4.4.1, and added some more runtime dependencies (again, in unstable): https://git.solus-project.com/packages/lutris/commit/?id=bc418a13b326e2699b3399e0b9668bea789442d8