Page MenuHomeSolus

Create AP - software to create a Wifi AP in Linux
Closed, DuplicatePublic

Description

Name: Create AP

Homepage: https://github.com/oblique/create_ap
Download: https://github.com/oblique/create_ap/archive/v0.4.6.zip

Description: This script creates a NATed or Bridged WiFi Access Point.

Why it should be included: A very handy script to replicate a Wifi network, acting as AP. I used it with several other GNU/Linux distributions, so that cellphones and tablets farther from the router can have good signal. It works wonderfully. But not all dependencies are in the repos.

Related Objects

Event Timeline

brunomiguel renamed this task from Create AP - software to create an Wifi AP in Linux to Create AP - software to create a Wifi AP in Linux.Dec 20 2016, 4:47 AM
brunomiguel created this task.
JoshStrobl closed this task as a duplicate of T84: Hotspot not working.Dec 21 2016, 9:24 AM
JoshStrobl added a subscriber: JoshStrobl.

Closed as a duplicate of T84 because we already have the functionality via Gnome Control Center for creating hotspots, it just needs to be fixed.

I think create_ap should be reevaluated. As far as I know the Hotspot function in the Gnome settings does not support WPA2.

@baimafeima I will be testing this as soon as I can. I've got an ath9k WiFi at work to provide local access to my mobile devices, but I need a second one for home for dev/testing uses. I'll be ordering one today and getting it about Monday or so.

What I'll be testing is actually the NetworkManager setup, initially, to see if it works, and if certain things work as expected over a period of time. One thing I saw, in the past at least, was the Network Manager hotspot method, when setting the AP to be hidden, after several hours to a day, it would unhide and broadcast itself unexpectedly, but did fully work with WPA2.