Page MenuHomeSolus

Matlab
Closed, WontfixPublic

Description

Hi,

Matlab installs without a glitch. However, there is no integration with Budgie. No .desktop files are created and I cannot find any icon files in /usr/share/icons. Not sure what's going on.

Debian based distros have a separate script which users run after installing Matlab, which takes care of these things. Have found this. The problem is, Matlab installation in Solus does not create a /usr/share/app-install/ directory at all.

Note: This does not affect immediate functionality as Matlab can be launched via the terminal. But it would keep a lot of scientists from trying Solus as Matlab is the most commonly used computational tool.

Event Timeline

The problem is, Matlab installation in Solus does not create a /usr/share/app-install/ directory at all.

That isn't a problem. We're not based on Debian or Ubuntu, we don't use that directory. We store .desktop applications in their correct place, which is /usr/share/applications

So you think this is to do with the MATLAB installer being geared towards a Debian install rather than the standard Linux directory structure ? If I can just get the location of the icon after installation I can try writing a simple script which sorts out the links and the .desktop.

JoshStrobl closed this task as Wontfix.Dec 23 2016, 11:05 PM
JoshStrobl claimed this task.

I have no idea. It isn't really our responsibility either to ensure Matlab is sanely implemented to be cross platform and follow specifications, given it's proprietary commercial software with a company behind it.