Page MenuHomeSolus

privoxy
Closed, WontfixPublic

Description

Privoxy is a non-caching web proxy with advanced filtering capabilities for enhancing privacy, modifying web page data and HTTP headers, controlling access, and removing ads and other obnoxious Internet junk. Privoxy has a flexible configuration and can be customized to suit individual needs and tastes. It has application for both stand-alone systems and multi-user networks.

I do not really know if Solus already has something like this.

JoshStrobl renamed this task from Add privoxy package to privoxy.Dec 14 2016, 2:14 PM

Indeed, thanks!

DataDrake triaged this task as Normal priority.Dec 15 2016, 3:16 PM
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.

I did try to package privoxy but I faced an issue I can't solve : Ideally the application should be installed with a dedicated user/group (the make install exit with a non-zero status when installed as root which causes the build to fail).

I did try to create the user/group before the make install but of course the build user does not have the permission to do that.
More info about what I did here.

ikey added a subscriber: ikey.Mar 17 2017, 2:02 PM

Check out the mock or samba packages for some group examples. The networkmanager-openvpn package containers a user/group sysusers example

./mongodb/files/mongodb.sysusers
./fuse/files/fuse.sysusers
./colord/files/colord.sysusers
./dbus/files/dbus.sysusers
./nginx/files/nginx.sysusers
./mariadb/files/mysql.sysusers
./docker/files/docker.sysusers
./httpd/files/httpd.sysusers
./vsftpd/files/vsftpd.sysusers
./usbmuxd/files/usbmux.sysusers
./netdata/files/netdata.sysusers
./networkmanager-openvpn/files/nm-openvpn.sysusers
./php/files/phpfpm.sysusers
kyrios123 added a subscriber: sunnyflunk.EditedMar 17 2017, 2:37 PM

That's what I did on advise of @sunnyflunk but the problem is that the user/group are not created immediately and they must exist before the make install command is executed.
I did also try to force a restart of the systemd-sysusers service (reload is not supported) but of course the build user doesn't have the permission to do this operation.

The install script checks if the user exists with the id command but it fails.

+ install -Dm00644 /home/build/work/files/privoxy.sysusers /home/build/YPKG/root/privoxy/install//usr/lib64/sysusers.d/privoxy.conf + make -j5 install DESTDIR=/home/build/YPKG/root/privoxy/install USER=privoxy GROUP=privoxy -s id: 'privoxy': no such user make: *** [GNUmakefile:801: install] Error 1 Command '['/bin/bash', '--norc', '--noprofile', '/tmp/ypkg-installQ_T8zs']' returned non-zero exit status 2 [Build] install failed ERRO[10:34:25] Failed to build package error="exit status 1" ERRO[10:34:27] Failed to build packages ...
Isawan added a subscriber: Isawan.Jul 29 2017, 7:03 PM
JoshStrobl closed this task as Wontfix.Jun 25 2018, 1:19 PM
JoshStrobl added a project: Needs Maintainer.
JoshStrobl claimed this task.

This has sat in accepted for inclusion for over a year. Clearly, there is a lack of demand for the inclusion of this software, nobody has stepped up to provide a patch, maintain it, and properly integrate it. Closing as a result. Feel free to reopen but only when someone offers a patch via our proper patch submission methods and volunteers to be maintainer.