Page MenuHomeSolus

sudo pip3 install doesn't work (pyconfig.h missing)
Closed, ResolvedPublic

Description

When I install python packages with "sudo pip install xxx" everything works fine. As soon as I use pip3 instead I get this :
error: invalid Python installation: unable to open /usr/include/python3.5m/pyconfig.h (No such file or directory)

This folder doesn't exists even though python3 is installed. I'm not sure what to do (I tried also to use a mkvirtualenv -p python3 but it fails for the same reason).

Cheers

Event Timeline

You need to install python3-devel which contains the header files it is asking for.

Perhaps pip3 should be moved to the python3-devel package

Works like a charm thanks

thanks i had that problem too

JoshStrobl closed this task as Invalid.Aug 12 2016, 4:46 PM
JoshStrobl triaged this task as Normal priority.
Tick reopened this task as Open.Aug 25 2016, 1:32 PM
Tick closed this task as a duplicate of T358: pip3 is broken.
Tick added a subscriber: Tick.Aug 25 2016, 1:35 PM
JoshStrobl closed this task as Resolved.Aug 25 2016, 1:51 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Don't reopen this issue. Install python3-devel as @sunnyflunk states.

JoshStrobl changed the edit policy from "All Users" to "Restricted Project (Project)".Aug 25 2016, 1:52 PM
JoshStrobl changed the edit policy from "Restricted Project (Project)" to "Triage Team (Project)".Aug 25 2016, 2:02 PM
Tick added a comment.Aug 25 2016, 4:12 PM

Oh sorry, I merged this issue with a new one (because I didn't see it before I post the new one), and I totally messed up with phabricator and I tried to restore this issue as it was before. :o

It's fine. Either way, this is something that should be looked into and potentially patched. Just ya know, please don't necro thingies.

Ok so the pyconfig fiel can be patterned into the main package, that's no issue. The problem still stands that in quite a few cases, the python3-devel package will be needed to be installed, along with system.devel, to build some extensions. Those can't be resolved in "normal" packaging, nor should they.