Page MenuHomeSolus

Tumbnails not loading and files not directly usable from NAS
Closed, ResolvedPublic

Description

When using the file explorer local images have a thumbnail but those on a NAS don't. It's also not possible to, for instance, upload a file from a NAS directly to the internet and some programs (eg. TeXstudio) fail when opening a file from a NAS.

Also when opening an image from a NAS it loads extremely slowly while it's instant on my Windows machine. This loading time got better with an update a while back so now it could be down to the image viewer not using the thumbnail first before loading the full image (this, however, could be related to the issue above).

Event Timeline

ElecProg created this task.Nov 27 2016, 4:59 PM
ElecProg added a comment.EditedNov 27 2016, 5:01 PM

The thumbnail part could be a setting in Nautilus but it seems you can't change its behaviour in the version in Solus.

Edit: You can't change its behaviour because you can't access (all) settings.

Samba or NFS? Because Samba on linux has always been awful slow for me.

Samba, maybe the speed is down to the implementation? I'm not an expert. However having thumbnails would make the 'slowness' liveable. The failing of software to work with files on a NAS, through Samba, is the most major issue.

Should I split the issue up into three? No thumbnails; failing to open files; and the slowness?

No need to split it up, a single issue is fine. I'm guessing that the thumbnails aren't loading because of how long it takes to access the files. Same is probably true for TexStudio not opening the file.

I've not spent much time on Samba in the past few years, so I'm not the best to help you sort it out. But that definitely explains the speed though.

ElecProg added a comment.EditedNov 29 2016, 7:25 PM

Could be, but when I googled the issue there were some fixes coming up like:

[...]In my case it was pretty simple: All I had to do is to change the preference in nautilus, by switching from "show thumbnails: only local files" to "show thumbnails: always" [...]

So, for the thumbnails specifically, it could be a setting in Nautilus (unfortunately I do not know how to change this setting in the version of Nautilus on Solus).

Something that might also signal a more significant issue is that when I try to upload a file in Chrome from a NAS or open a file in TeXstudio from a NAS etc. it fails instantly without any noticeable delay. Some programs do open the file (eg. LibreOffice which, if I remember correctly, makes a local copy of the file to work with) and some seem to open but then show an empty file (eg. Visual Studio Code).

So my guess is that there is a problem with external files. (Another signal would be if the before mentioned setting in Nautilus doesn't fix the thumbnail problem, something I can't test unfortunately.)

fluffymadness added a subscriber: fluffymadness.EditedDec 13 2016, 12:55 PM

I also have the problem that I can't play any videos from my nas, neither with vlc nor smplayer
(My smb share has credentials btw)

http://askubuntu.com/questions/618204/cannot-play-files-over-samba-share-on-mate-15-04
....In Ubuntu 15.04, 15.10 there is a confirmed bug in the gvfs package. This causes any mounts made no to show up in /run/user//gvfs.....

and indeed...for me nothing is mounted there.
Maybe thats somehow related to the problem

Same problem described here
https://bbs.archlinux.org/viewtopic.php?id=203844

Hopefully this can be fixed somehow

fluffymadness added a comment.EditedDec 16 2016, 10:58 AM

I played around a bit and kinda got it working.
Can anyone try this:

Unmount any active network share in nautilus before, then open a terminal

killall gvfsd-fuse
sudo umount -l /run/user/1000/gvfs
/usr/lib/gvfs/gvfsd-fuse /run/user/1000/gvfs -f -o big_writes

The last command doesn't finish. It's ok, leave the terminal open.
Try to open the share in nautilus again, play a video, it should work, at least for me it does.

If you look at /run/user/<id>/gvfs/
you should see you share now.

If you open Nautilus, you can click the icon in the upper left of the window and go to preferences. If you then go to the Search & Preview tab, you can change when thumbnails are created. Note: there is also a dropdown for size which will limit how large of a file to read for thumbnails.

DataDrake triaged this task as Normal priority.Dec 29 2016, 1:44 AM

Ok, thanks that fixes the thumbnails part.

I've been digging into the performance issues of samba, it seems to be down to configuration. https://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/speed.html if someone wants to do the hard work of tuning the defaults. Adding the line socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536 to the global settings in /etc/samba/smb.conf already made a huge difference for me but I guess there is more work to be done there...

The

It's also not possible to, for instance, upload a file from a NAS directly to the internet and some programs (eg. TeXstudio) fail when opening a file from a NAS.

part, is still a mystery though....

DataDrake closed this task as Resolved.Feb 23 2017, 2:02 PM
DataDrake claimed this task.

@ElecProg I suspect that your second issue is a matter of latency to the NAS itself. There are quite a few programs that will "freak out" if file I/O takes too long. I'm going to close this since the initial issue of thumbnails not loading has been resolved. It's becoming clear that this and other issues are pointing to our Samba being less than optimal. So, I'm sure that will be on a TODO list soon.