Page MenuHomeSolus

Mariadb 10.1.19
Closed, DuplicatePublic

Description

{F7839}Mariadb 10.1.19. Note - creation of the database after package install but before service start must be performed with:

  1. sudo su -
  2. cd /usr
  3. ./bin/mysql_install_db --datadir=/var/db/mysql/data --basedir=/usr
  4. chown -R mysql:mysql /var/db/mysql

I didn't see a nice way to do this automatically as there appear to be no post-install triggers, and of course this logic should be wrapped with safety checks. Obviously you don't want the package shipping any of those files under /var/db/mysql...

Related Objects

StatusAssignedTask
Wontfixalecbcs
Resolvedalecbcs
WontfixJoshStrobl
ResolvedNone
WontfixJoshStrobl
WontfixJoshStrobl
InvalidNone
ResolvedJoshStrobl
InvalidNone
Duplicateikey
rnesius created this task.Nov 22 2016, 5:14 AM
rnesius updated the task description. (Show Details)

Edited task to add the patch... hope I did that right.

ikey changed the task status from Open to In Progress.Dec 4 2016, 10:59 PM
ikey claimed this task.
ikey added a comment.Dec 5 2016, 1:35 AM

Patch merged in @ https://git.solus-project.com/packages/mariadb/commit/?id=cbb069a33823f9e7a2d60cbac1ece78878b7c8c0
First set of my changes in @ https://git.solus-project.com/packages/mariadb/commit/?id=f0ccf211e08d4463ada579b4c6a5b478f6f16979

More to come yet, MariaDB is a beast! Thanks for doing the initial work on this, really appreciate it =)

DataDrake triaged this task as Normal priority.
ben added a subscriber: ben.Feb 7 2017, 11:41 PM
euoar added a subscriber: euoar.Mar 5 2017, 2:01 AM
sd added a subscriber: sd.Apr 19 2017, 10:47 PM
ikey added a comment.May 12 2017, 9:04 AM

Merging into T80 - as its a dupe

ikey closed this task as a duplicate of T80: MariaDB.May 12 2017, 9:04 AM