Page MenuHomeSolus

Wine-gaming-nine
Closed, ResolvedPublic

Description

Wine-gaming-nine is wine with the gallium patches; it can increase performance in some games, most especially, with amd cards.
Source: https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-1.9.22.tar.gz
https://github.com/wine-compholio/wine-patched/archive/staging-1.9.22.tar.gz
https://aur.archlinux.org/packages/wine-gaming-nine/

Event Timeline

DataDrake closed this task as Wontfix.Nov 6 2016, 4:49 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

These patches are version specific to each version of wine. That means every time a new wine package is released we would have to wait for this project to update their packages before updating wine. That's a bad practice. If they really want these patches in Wine, they should be contributing them to the upstream and not maintaining a separate git repo of just patches.

Espionage724 added a subscriber: Espionage724.EditedNov 6 2016, 7:17 PM

As I understand, upstream Wine won't take Gallium Nine patches since they only benefit Linux. I'm not sure if Staging will take it, but I assume they either follow the same reason, or have their own reasoning if they didn't take it already.

I hadn't thought about Gallium Nine for a good while now since I've gotten NVIDIA, but I relied on it heavily back on my AMD system, but if I was still on AMD (or even had a NV GPU that worked well with nouveau), I'd definitely need Gallium Nine-patched Wine.

Commander-Zal awarded a token.EditedNov 6 2016, 11:17 PM
Commander-Zal added a subscriber: Commander-Zal.

I was going to request this myself, as I too use AMD, and Gallium Nine can give absolutely massive performance gains for AMD cards, often times doubling the framerate in games.

As Espionage said, upstream Wine refuse to accept Gallium Nine patches, as they don't like the amount of code it would introduce for such a small audience (AMD Linux users).
However, as you can see here, Wine with Gallium Nine can not only increase performance, but also eliminate certain graphical glitches in games.

Is there no way to have a seperate version of Wine specifically for Gallium Nine, similar to how PlayOnLinux can have multiple versions installed at once?

I personally find it to be a critical app, it'd be a great shame if it can't make it into Solus :(

I read somewhere(phoronix perhaps?) that gallium nine will eventually be merged into staging.

Can I get confirmation on that @fagoatse ? Sorta hinging on that fact

I can't find where gallium nine will eventually be merged into staging. It seems it will remain as patches, but it seems as if wine-gaming-nine is kept updated and the performance improvement on AMD cards is very impressive.

dan_ added a subscriber: dan_.Mar 28 2017, 12:14 AM

Any updates on this? I was thinking of running Solus but I play World of Warcraft and just got an r9 fury. It is easy to use gallium on ubuntu/suse/arch but wanted to give Solus a try. Not being able to play wine games with reasonable frames might be a deal breaker.

ikey changed the task status from Wontfix to Resolved.Apr 26 2017, 12:04 AM
ikey claimed this task.
dan_ added a comment.Apr 26 2017, 12:46 PM

Legit, awesome. I wants to test it. How do I get the new hotness? Wait for an update or do I need to run an unstable repo or something?

phinicota added a subscriber: phinicota.EditedApr 26 2017, 2:22 PM
In T1496#61149, @dan_ wrote:

Legit, awesome. I wants to test it. How do I get the new hotness? Wait for an update or do I need to run an unstable repo or something?

I suppose the update server will sync soon? I got a little anxious and compiled it myself.
Just clone and compile those three packages from git.solus-project.com (btw, you only need pulseaudio if you want sound on wine).
If you need more details, I can provide the steps I followed.

It's in unstable for now, I'm hoping for a sync tonight.

dan_ added a comment.Apr 26 2017, 10:44 PM

I think I can wait. :)

solo added a subscriber: solo.EditedApr 27 2017, 9:04 AM
In T1496#61149, @dan_ wrote:

Legit, awesome. I wants to test it. How do I get the new hotness? Wait for an update or do I need to run an unstable repo or something?

I suppose the update server will sync soon? I got a little anxious and compiled it myself.
Just clone and compile those three packages from git.solus-project.com (btw, you only need pulseaudio if you want sound on wine).
If you need more details, I can provide the steps I followed.

Can you list your steps please? I cloned and compiled all three but my libstdc++ is not up to date enough to install the mesa package. Can I not install these git packages unless I'm on unstable? Thanks

dan_ added a comment.EditedApr 29 2017, 2:48 AM

How should I report how things are going? Here or elsewhere? With the new patches I am able to run wine, check the use gallium nine checkbox and run games. Unfortunately there are a lot of artifacts. I am trying to find out in the d3d9 channel on irc what the issue is as I have identical issues when running gallium nine on fedora, but not on ubuntu. I have linked a screenshot so that you can see what I mean, as well as a pastebin of what happens when I run it from the terminal. I tested both with and without the "enable gallium nine" checkbox checked. When i run "wine Wow-64.exe" it tells me that Direct 3D Nine is active. So, it is working, but something is not working right. I have tried multiple games and there are artifacts present in all of them.

http://imgur.com/a/MPndn
https://pastebin.com/kTPAGC0w

dan_ added a comment.EditedApr 29 2017, 4:04 AM

Okay, I happened across a fix? I installed steam and now all my graphical problems are gone. I don't know what dependency steam must pull in but it fixed all my issues.

Ty ikey for all the effort put into this. As this was the last piece of the puzzle for my daily driver, I can now officially call Solus home. :)

Have you checked with latest commit?

Also, I noticed the package was bumped to version 2.7 to match wine release, but is still using d3d9 patches for wine 2.6...

Also, I noticed the package was bumped to version 2.7 to match wine release, but is still using d3d9 patches for wine 2.6...

Because 2.7 patches aren't available yet. And they're working fine. Also note that the latest update that came through
added the missing runtime dependencies. It was libtxc_dxtn-32bit, this has all been resolved.

@phinicota the package that's in the Solus repos now works fine. I'm also unsure why you have a forked version of it on
GitHub that is actually behind ours, and has none of the enabling required :)

STiAT added a comment.EditedApr 30 2017, 6:19 PM

I just reactivated my WoW acc to check it (after the battle.net wine issue was solved thanks to @ikey as well :D).

  • do not see graphical glitches
  • performance is a lot better on my rx460 compared to native wine. The difference is actually pretty huge.

I'd confirm that this one works.

That text in your comment is unnecessarily *huge* on the home page. I may have snorted aloud.

STiAT added a comment.Apr 30 2017, 6:29 PM

I edited it already :D..

I tend to use "=>" for lists, but phab does not like it a lot as it seems (that's why I changed it later).

Oh no need to edit it, just pointing out that I found it funny :P

In T1496#62055, @ikey wrote:

@phinicota the package that's in the Solus repos now works fine. I'm also unsure why you have a forked version of it on
GitHub that is actually behind ours, and has none of the enabling required :)

That fork is actually based on wine-staging. I hadn't seen the update on solus repo. I'll update it ASAIC.
I know it still needs some modifications but I haven't had the time to explore solus packaging and it seemed to be working fine.

If you have a better suggestion as to enable the distribution of such a package I'd be happy to help.

STiAT added a comment.Apr 30 2017, 8:11 PM

That's a hard line. My personal thing is .. I think they jumped over the shadow already going from wine stable to wine dev releases (and knowing now that we had build issues I think it wasn't even necessary to switch to development releases at all). Going from development to even staging with unaccepted patches .. well, ye, introduce the patches if there is a solid reason as there is with the -nine patch.

You could try to request a wine-staging package here, but it does not fit Solus policy, so I doubt it would be accepted. Not my call though, the ones doing the calls are certainly - the developers.

Tbh I'm gonna settle for stabilising our package and not unnecessarily chasing things. I really don't want conflicting wine* packages in the repos.
I want one wine package that does a great job for everyone.

Just for the record, I'm not trying to push wine-staging on Solus. I understand the developers position on this.

I'm just trying to provide an alternative for DIY Solus users (outside of the Solus project). In the spirit of not producing any conflicts I've even removed the author even though I've barely modified the official package.

I think you're misunderstanding me quite a lot here @phinicota - I'm not talking about project or personal conflicts. I'm talking about having two packages that have
conflicting paths on disk :P They literally cannot coexist, which is poor design, something we avoid in Solus. Making the wine we have (and hell anyone is welcome to contribute)
work well for everyone is a good design decision. Having multiple forks of the same thing for different purposes is typically what you would find on Ubuntu with PPAs, leading
to a poor user experience.