Page MenuHomeSolus

lightdm is segfaulting
Closed, InvalidPublic

Description

I see this in dmesg, where "X" varies from boot to boot but the rest seems constant:

lightdm[X]: segfault at 0 ip 00007Xe26 sp 00007ffeX8 error 4 in libc-2.24.so[7fX000+1bc000]

Event Timeline

DataDrake closed this task as Invalid.Dec 29 2016, 2:18 AM
DataDrake added a subscriber: DataDrake.

Can't reproduce. Sounds like a failed update or something similar.

BAkfr reopened this task as Open.Mar 15 2017, 8:18 AM
BAkfr added a subscriber: BAkfr.

This bug is still present with lightdm 1.15.0-15.
I've not noticed any visible behavior, except the kernel message.
It appears at each boot.

journalctl --since today | grep lightdm
mars 15 08:15:56 dryade.ebak.fr lightdm[709]: Could not enumerate user data directory /var/lib/lightdm-data: Error opening directory '/var/lib/lightdm-data': No such file or directory
mars 15 08:15:56 dryade.ebak.fr lightdm[709]: Could not create user data directory /var/lib/lightdm-data/lightdm: Error creating directory /var/lib/lightdm-data/lightdm: No such file or directory
mars 15 08:15:56 dryade.ebak.fr lightdm[767]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
mars 15 08:15:56 dryade.ebak.fr systemd-logind[702]: New session c1 of user lightdm.
mars 15 08:15:56 dryade.ebak.fr systemd[775]: pam_unix(systemd-user:session): session opened for user lightdm by (uid=0)
mars 15 08:16:06 dryade.ebak.fr lightdm[767]: pam_unix(lightdm-greeter:session): session closed for user lightdm
mars 15 08:16:06 dryade.ebak.fr lightdm[709]: Could not create user data directory /var/lib/lightdm-data/bak: Error creating directory /var/lib/lightdm-data/bak: No such file or directory
mars 15 08:16:06 dryade.ebak.fr lightdm[805]: pam_unix(lightdm:session): session opened for user bak by (uid=0)
mars 15 08:16:06 dryade.ebak.fr systemd[776]: pam_unix(systemd-user:session): session closed for user lightdm
mars 15 08:16:07 dryade.ebak.fr kernel: lightdm[833]: segfault at 0 ip 00007f7898971e26 sp 00007ffe2573ec68 error 4 in libc-2.24.so[7f78988e5000+1bc000]
mars 15 08:16:07 dryade.ebak.fr lightdm[805]: gkr-pam: unlocked login keyring

Can confirm that this still happens. Checked it on multiple machines

goniz added a subscriber: goniz.Apr 26 2017, 8:39 PM

still happens here as well, fresh install + upgrade (budgie desktop).

Is this still an issue?

DataDrake closed this task as Invalid.EditedOct 16 2018, 8:16 PM

Closing due to lack of response in over 30 days.