Page MenuHomeSolus

Mouse cursor fails to hide in fullscreen video
Closed, ResolvedPublic

Description

Issue:
Mouse cursor fails or only partially hides in full screen mode or when hovering over content that requires the mouse to be hidden. Doing any of the mentioned results in the mouse becoming a square black block with lines through it.

Hardware specs:
System: Host: sol Kernel: 4.7.0 x86_64 (64 bit gcc: 6.1.0) Desktop: Gnome

Distro: Solus 1.2.1 shannon

Machine: System: LENOVO (portable) product: 80H1 v: Lenovo Edge 15

Mobo: LENOVO model: Lenovo Edge 15 v: 31900058 WIN
Bios: LENOVO v: B9CN16WW date: 12/26/2014

CPU: Dual core Intel Core i7-4510U (-HT-MCP-) cache: 4096 KB

flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10375
clock speeds: max: 3100 MHz 1: 2176 MHz 2: 1999 MHz 3: 1999 MHz
4: 1997 MHz

Graphics: Card-1: Intel Device 0a16 bus-ID: 00:02.0

Card-2: NVIDIA Device 1341 bus-ID: 04:00.0
Display Server: X.Org 1.18.4 drivers: nouveau,intel (unloaded: fbdev,vesa)

This may be a dual graphics issue in which case I am aware Ikey currently doesn't have access to a machine with this setup and am open for any testing to try and resolve the issue.

[Edit:] It seems this is a Intel graphics related issue at the moment not a dual graphics issue.
[Edit #2:] This issue is confirmed to be affecting more than just Firefox.

Event Timeline

I am also experiencing this in my YouTube videos under Chrome stable. I have not tried this with Firefox of Totem as of yet. I am also using an i7 processor with an Intel graphics card if that helps.

crash added a subscriber: crash.Aug 12 2016, 7:49 PM

yeah i got this as well under firefox on pages and under fullscreen youtube watching

Seeder101 added a subscriber: Seeder101.EditedAug 13 2016, 6:33 AM

hi, I'm r00tobo from the IRC channel, as I said to crash I will post my action to this issue
now when I use mpv player the cursor is disappear as expected but the youtube player in the firefox make the cursor like an animated thing and it does not disappear...I will try to take a screenshot and post it here

ADDONS:

I tried totem player and it does work fine...

now I'm trying to take a screenshot with the prntscreen button on the keyboard and that does not take any effect =p

I tried to change the cursor theme...but there's no more than the breeze one ...

I managed to take a screen shot from my mobile



You see the white dots there ?

Can confirm that switching from breeze-snow-curser to Adwaita (default theme) does not fix the issue. Also can confirm this happens while using the Solus live media as well.

Used the live media to test this bug in order to narrow down that it isn't due to any custom settings on my part. Bug persists.

Here you can find many/all available cursor modes. From there you can tell that a bunch of them are broken (I dunno why)... so I guess YouTube uses one of those broken cursors.

Works on my system as expected in chrome, firefox, totem but not in vlc.

In vlc the curser disappears but does not allow double click for fullscreen and in fullscreen mode there is no popup menu shown on mouse movement. The only thing working in vlc on the video is right click

Happens to me, too, in Firefox. Not just on YouTube or any videos (while the cursor is hidden, a.k.a. "distraction-free/idle mode"), but on different sites on different elements like buttons, or for example on ImgUrl while I move the cursor over a picture. I have a very fresh installation of Solus (it's up since a couple of hours). First I saw this issue when I used YouTube without updating anything and I thought maybe patching everything make it disappear, but it didn't. And so far Solus is the only distro where I saw this.

My PC is an Asus X550LB notebook with dual graphics, but it's not an Nvidia bug, because I don't use it, the driver is not installed.

lnx4tw added a subscriber: lnx4tw.Aug 29 2016, 11:52 AM

I can confirm that this happens for me as well, but it only seems to occur when I am using Remmina. I thought it was an issue for either freerdp or remmina, so I have been attempting to build the newest packages of those applications (wip). The screenshots above are exactly what the cursor shows up as whenever moving into a windows rdp through Remmina. Vinagre works fine, but it doesnt attempt to change the cursor from the default Breeze cursor.

This problem appears on maps too : Open Street Map example

My pc is a lenovo x1 carbon
CPU : Intel® Core™ i7-5500U CPU @ 2.40GHz × 4
GPU : Intel® HD Graphics 5500 (Broadwell GT2)
System : Solus 1.2.1 up to date
Firefox : 48.0.2

linuxhelmet added a comment.EditedAug 29 2016, 9:08 PM

GrisuProjects can confirm that the following cursor icons do NOT work with all updates applied while using the site you listed. Found this issue does not affect Google Chrome on my system. Everything works fine on Google Chrome. Only Firefox.

none
progress
vertical-text
copy
nesw-resize (black box)
nwse-resize

Could it be that there is a coding issue in the custom version of Firefox that Solus offers? Or just a CSS coding issue?
It also seems this affecting people with Intel graphics particularly as I am only running the default open-source drivers not the proprietary via Nvidia.

Also soulflyman it appears your issue is with VLC. You may want to try posting your issue as a new bug, although honestly I tested using vlc and yes only right clicking allows for the menu to pop-up which allows you to exit fullscreen. I don't see this as a bug so much as just a missing feature that the Windows/other versions of VLC may have. Double-clicking is just not present.

If it really is the custom built Firefox's issue, I really hope that it could be solved by some patching and not by changing to the default one. Solus's browser has way better speed and look than what Mozilla currently offers.

I actually installed a fresh tarball of Firefox on live usb to test this on and found that I was still seeing the issue. Maybe it has something to do with the mouse theming in correlation to Firefox itself? Not sure...

linuxhelmet added a comment.EditedSep 7 2016, 11:24 PM

I think I've pretty well narrowed this down to a CSS issue as it isn't displaying certain mouse pointers correctly. I know nothing about CSS maybe someone else can fix this?

cyber-doug added a comment.EditedSep 8 2016, 12:19 AM

You can reproduce this when hovering some images like this.
It also happens within MyPaint application, all over the drawing area. I only have Intel graphics.

linuxhelmet updated the task description. (Show Details)Sep 19 2016, 1:50 PM

It's not Firefox specific, sadly.

linuxhelmet updated the task description. (Show Details)Sep 19 2016, 4:29 PM
linuxhelmet updated the task description. (Show Details)
underskore added a comment.EditedSep 21 2016, 3:37 PM

I have AMD CPU/GPU, so this issue is not just Intel's.

DataDrake triaged this task as High priority.Sep 24 2016, 1:52 PM
Jarh57 added a subscriber: Jarh57.Oct 11 2016, 8:14 AM

I have this issue while running a Windows 7 VM via Gnome Boxes. The issue started after installing the QXL video driver in the VM.

See video of issue here

ikey closed this task as Resolved.Oct 16 2016, 11:43 PM

Resolved by building Firefox against GTK2, instead of GTK3:
https://git.solus-project.com/packages/firefox/commit/?h=firefox-49.0.1-72

This update is now in the stable repo, please apply all updates and restart Firefox (or your system if you haven't already got the kernel
updates)

sudo eopkg up

It appears this bug may have returned, as I experience the corrupted mouse cursor with Firefox on youtube videos and on the image Cyber-Doug linked to above.

My install of Solus has been fully updated with the latest Firefox 49.0.2 and Kernel 4.8.3, using Radeonsi drivers with a 7770 GPU.

Can confirm, was about to write the same exact thing this very minute. Lest this gives the impression of a "Me too!" post, I wanna mention that this also happens in the Epiphany browser. (No idea when this occurred for the first time, I installed it just this morning.)
Ikey mentioned earlier in the thread that the glitch isn't Firefox-specific, so I don't know whether this warrants a new ticket.