Page MenuHomeSolus

ONLYOFFICE Desktop Editors - OFFICE suite (AGPL3)
Closed, WontfixPublic

Description

http://www.onlyoffice.com/apps.aspx

ONLYOFFICE Desktop Editors include the following editors:

ONLYOFFICE Document Editor
ONLYOFFICE Spreadsheet Editor
ONLYOFFICE Presentation Editor

binary:
http://www.onlyoffice.com/download-desktop.aspx

source:
https://github.com/ONLYOFFICE/desktop-apps
https://github.com/ONLYOFFICE/desktop-apps/tree/master/win-linux

Event Timeline

Why is this needed when we already have LibreOffice?

Because it's beautiful and very responsive and looks consistent with Solus desktop theme. Libreoffice is slow. Also we already have WPS Office as 3rd party office suite.

Because it's beautiful and very responsive

That's great and all, but it's all subjective. What I care about is functionality. and LibreOffice provides that.

Libreoffice is slow.

Then we either need to optimize LibreOffice or they need to.

Also we already have WPS Office as 3rd party office suite.

I'm aware. This basically looks like WPS Office and we don't really need another one of those.

Solus isn't a UX-first distro. We're architects, not painters.

We don't introduce things because they look pretty, but because they provide quality & function per user demand.
What is this able to do that LO can't?

WPS Office is a different matter entirely, made accessible for Chinese users.

utybo added a subscriber: utybo.Oct 30 2016, 4:15 PM

ONLYOFFICE can also be installed through a GUI, so a package is not entirely necessary here.

LibreOffice are working on a NotebookBar: https://wiki.documentfoundation.org/Development/NotebookBar which is very similar in looks and functionality to what OnlyOffice has to offer.

Not sure whether it's already going to be available in 5.3, though.

Let's see how solus can make the sluggish Libreoffice faster. MS office even with wine starts up way too faster.

The banes of Desktop Linux is Libreoffice and Firefox, as both of these are very slow to start up. And unfortunately only these beasts provide the full functionality which no other software can provide.

I just installed windows 10 and I am awestruck to see how smoother and fluid windows 10 is compared to previous windows version or any flavor of Linux on the same machine. The very light weight desktops like xfce, etc are snails. Apps launch instantly like an android phone.

I love solus for this only, the performance optimization. Hope you guys will do great things with solus!

JoshStrobl closed this task as Wontfix.Oct 31 2016, 1:39 PM
JoshStrobl claimed this task.
JoshStrobl changed the edit policy from "All Users" to "Triage Team (Project)".

Someone link me to a review or video of this please

Unknown Object (User) added a subscriber: Unknown Object (User).Mar 3 2017, 7:33 PM
Unknown Object (User) added a comment.Mar 3 2017, 8:11 PM


For some reason, its font rendering isn't very nice on Solus though. (No, the text is not set to bold.)
I tried it on other systems and it generally is surprisingly nice (feature-, interface-, and compatibility-wise), I have no idea why this isn't more popular, it certainly feels much better than LibreOffice...

Unknown Object (User) added a comment.Mar 3 2017, 8:29 PM
This comment was removed by Unknown Object (User).

For what it's worth in my experience ONLYOFFICE displays Microsoft Word documents much more accurately than LibreOffice.

FB added a subscriber: FB.May 5 2017, 2:31 PM

To my point of view, Microsoft Office is still the (only) reason why Microsoft needs to be used.

Working on Linux, I am still looking for a good alternative. For sure, I use LibreOffice which is good, but the problem is that the formatting of native Microsoft documents (Word, Excel) opened in LibreOffice is too often broken. Moreover, the great feature "Format as Table" in Excel (that is used in about 100% of my professional documents) are not well supported in LibreOffice. To summarize, LibreOffice is not really a functional alternative to Microsoft Office.

I have also tried WPS Office, which keep the formatting much better than LibreOffice.

Recently, I discovered OnlyOffice. It is a great Office suite. In term of compatibility with Microsoft Office, it is much much better. It also has a better support for "Format as Table".

I don't think that having multiple Office suite, in Solus, is bad. Each Office suite (LibreOffice, OnlyOffice) have pro and cons. By the way, for my professional documents which requires to keep well the formatting, I found out that OnlyOffice is a much better choice.

I hope that Solus team will, once, change their position and that OnlyOffice (dekstop) will be available soon...

@FB what about microsoft office online ? perhaps it could be a solution for you ?

FB added a comment.May 8 2017, 6:45 AM

@kyrios123 : Thanks, it is an option, but I prefer offline tools.

Find here a demo made by Microsoft, to compare their product with Google Docs:
http://whymsft-public.sharepoint.com/Pages/google-documents-vs-word-web-app.aspx
And here a 3 years old video from Teamlab Office (now OnlyOffice), using the document above:
https://www.youtube.com/watch?v=0S0Op2MbLvw
You can download the Microsoft Word document (as explained in the video) and try yourself, with LibreOffice and OnlyOffice, to make your own opinion.

Sorry for opening a new task.

I'll give my opinion about this, and the general way you are handling the repos.

I get you don't want get clogged by hundreds of software to update and maintain. But people like options. Having a full fledged repo is important for users, not only for newcomers, but also for experienced users that opt to use Solus, and this is happening daily now.
So, unless you add third-party repos, so people can organize, mantain and deploy their software, in a way you can't, or don't want do, you will be getting more and more package requests for software that has similar functionality to the ones you already have.

I hope OnlyOffice gets included, or, if it is not included, at least all dependencies for build get included in the repo, so the community can provide build tutorials for people that want to have this software.

@kyrios123 Like I said, I get there will be some options for package distribution. But now, we are not there yet.
And if we had as many tools, and packages to the repo, things start to get interesting for everyone, developers, power users, or just granny wanting a nice looking office suite.

http://www.omgubuntu.co.uk/2017/05/wps-office-linux-on-halt

Now that non-free office suite - wps office is not going to be updated. Hope someone makes a flatpak for the free software office suite.

JGH1000 added a subscriber: JGH1000.EditedJun 6 2017, 6:15 AM

+1

For me, even on a quite high end desktop (8 Cores, 64 GB, EVO Pro 950, Dual Titan X) LibreOffice is slow to open, keeps crashing, the UI does not scale well with a 4K screen, and compatibility with MS Office is abysmal (I collaborate a lot and need to borrow a Mac just to fix the formatting every other day..).

WPS would be great IF they support HiDPI, and this is not likely (thought I emailed them and they seemed open to it and very polite). OnlyOffice 4.3.2 has full hidpi support.

Office is one of the reason I really think about dropping Linux. Nothing against Solus as it's a superb distro that works so much better than anything I tried before (with 1/10 of time involvement compared to Arch), but the desktop office suites leave a lot to be desired.

Edit: Forgot to add, I did test it on Solus. Bunch of terminal error messages but it seems to work. Looks great, is fast and MS documents open without problems that I see in Libre. Portable version is not ideal as no updates and it's slower.

Office is one of the reason I really think about dropping Linux. Nothing against Solus as it's a superb distro that works so much better than anything I tried before (with 1/10 of time involvement compared to Arch), but the desktop office suites leave a lot to be desired.

If you want MS Office essentially for work, why not use

  1. virtualbox+ms windows+ms office (which is a better solution) and / or
  2. wine+ms office

The problem in Linux desktop is multi toolkits (gtk, qt, wxwidgets, vcl, etc.)

Also the most important and most used applications are the slowest to launch in Linux, firefox takes 10 seconds to start, libreoffice too.

libreoffice restart takes 2 seconds, whereas this onlyoffice desktop editors under 500ms.

This is pathetic user experience in every Linux distro with firefox and libreoffice are slow to launch, though they are feature rich and useful.

Does anyone know how ONLYOFFICE Document Editor compares to Calligra Words in terms of speed, stability, usability and features?

@fastrizwaan I could install Windows in VB but I might as well have Windows in this case - I really would like to stick to open source and linux but the office is making it difficult.

Wine 2.0 support Office 2013 so maybe I will take the plunge. WPS is actually really fast and compatibility is good but the UI is tiny on a 4K screen. OnlyOffice seems quite good, not perfect and UI problems are still there, but it's best I found so far.

I agree with Firefox, but then again, if you care about privacy it's the only choice. Plus they are switching to servo and redesigning to there is hope.

@baimafeima Calligra is quite old as far as I know and can't compare to any modern suite.

Quick question to @JoshStrobl - why is it OK to have so many browsers in the shop (Firefox, Chrome, Vivaldi, Midori, Opera, Gnome Web, QupZilla, Uzbl [??]) but it is not possible to have 3 office suites?

I am using a portable version so it is not like it's impossible to use but having to launch it through a terminal, no updates etc is quite a downer.

I appreciate Solus vision but as mentioned, the current selection is very poor for someone with a 4K screen and need for good compatibility. LibreOffice can't even save a table without screwing it up for MS Office..

Many thanks!

I am jumping on the OnlyOffice train. My LibreOffice is completely unusable at the moment and I have too many complaints from colleagues and friends with compatiblity issues.

In addition to facilitating the installation or the good UI that has OnlyOffice that will improve in its next version, it counts on a better support for documents in format OOXML besides ODF, what allows to even use complex documents of excel without problems. The interface responds best in HiDPI resolutions and for small monitors above all it allows the connection with the online version with access to collaborative editing (in addition it is compatible with Nextcloud/ownCloud instances) and with an active development, so it currently makes it a better alternative to WPS Office IMHO.

I understand that it is not good to include a lot of software that does or intends to do the same, but OnlyOffice offers a balanced and accessible solution for users extending functionality in some areas in which LibreOffice still has setbacks. I suppose it is a good idea to consider the options according to their evolution.

I understand that it is not good to include a lot of software that does or intends to do the same,

Come on, Solus has only ONE

  1. Web browser,
  2. Desktop Environment,
  3. Music Player,
  4. Video player,
  5. Encoder,
  6. Decoder,
  7. Text editor,
  8. File manager,
  9. Office suite,
  10. Torrent client,
  11. API,
  12. IDE,
  13. Shell,
  14. Display server,

15 Kernel,

  1. Programming language,

Can't you see the ONENESS in Solus!?

Can't you see the ONENESS in Solus!?

Please, this is not about lowering the level of discussion to "look, your criteria is not met" when you are talking about something else, such as the qualitative features of a specific software. Solus supports more than one desktop environment and even - following your list - the issue is not reduced to debate if only one MP3 decoder is included and not another AAC because it would be stupid.

My argument is based on that OnlyOffice does a better job than WPS and offers unique features, such as the import of DjVu document, online collaboration, advanced support of MS Office features for OOXML documents, etc. and therefore complements LibreOffice, which makes it an option to be included.

Is your argument just because Solus doesn't include a single software to do one thing? meh...

maxiclo added a subscriber: maxiclo.EditedNov 25 2017, 8:29 AM

I don't understand the note that Solus isn't a UX-first distro considering Solus is based on three different GUI systems (on redesigned Budgie); it is not cmd line based linux distro! You should also consider that nowadays 4K screen are becoming more and more common and LibreOffice don't use vector toolbar icons but ugly icons that doesn't scale.

Wps office is another example. It is completely unusable on a 4K screen systems. It doesn't scale at all and it is immature for linux! But It is present in the third party package.

OnlyOffice would be a welcome package.

Juankz added a subscriber: Juankz.Dec 11 2017, 5:05 PM

Hello, just want to say ONLYOFFICE would be a good addition because of its compatibility with MS Office and because it is free/open source unlike WPS. But I am curious, is this being considered? Or is it already closed?

My two-cents:

OnlyOffice's compatibility with MS Office file formats is significantly better than any other Linux office suite currently available. LibreOffice and WPS simply aren't doing it well enough for me to consider them as substitutions as I progress further into my studies and field; MS formats are, for better or for worse, everywhere and expected. As a student who needs to work in teams on a regular basis, I need to be able to make and read documents from other people without the formatting getting messed up because of some weird issue LibreOffice has with reading docx line spacing. LibreOffice and LATEX or whatever is not something I would consider touching or using, ever, as I shouldn't need multiple programs to output a well formatted document.

Like WPS Office, OnlyOffice provides only the basic programs, albeit highly polished; a word-processor, a presentation-tool, and a spreadsheet. This is all I need for the work I do and despite Solus offering LibreOffice up piecemeal, I cannot help but feel LibreOffice is too bloated. I've tried LibreOffice on a multitude of systems and it is always the slowest office suite available. We have WPS Office as an alternative, currently, which is much lighter than LibreOffice, but is closed source, uses a relatively abandoned file format, and has a workflow all too similar to Office 2016, which I find inefficient.

Speaking to workflow, OnlyOffice offers an interface similar to the MS Office before it took the ribbon interface way too far. It works, is fast, and looks good while doing it, which is always a plus. In comparison, LibreOffice has the pre-ribbon interface that, for some, turns them off. The MUFFIN system for LibreOffice is incomplete and, to be frank, looks awful in tabbed mode with the other modes glitching out often enough I would consider them entirely unreliable. I feel OnlyOffice works better as a system in comparison to LibreOffice. The document tabbing is also a HUGE plus for me, as I often need multiple documents open at once.

If we want more people to migrate to Linux, then we need to modernize some things, like workflow and UI choices, which OnlyOffice entirely fulfills. Solus advertises its flagship Budgie Desktop as a luxurious, beautiful system for the modern age; the programs that run on the system should mirror this as well. Some may cry foul to this idea, but we can't move forward if we stay stuck in the past, regardless of the improvements made by modern UI design methodologies simply because of some values held by so few. Keep LibreOffice, let people have their choice.

OnlyOffice is a better choice than WPS Office, in my opinion, as it serves the same functions, but better adheres to the values of the Linux Community without hurting itself by refusing to move past old design languages. If you MUST have only two options for an office suite, drop WPS Office and switch to OnlyOffice. I feel, however, that choice would be hypocritical, as, in the context of that two-option limit, we already have too many web browsers, text editors, themes, desktop environments, programming IDEs, and PDF viewers in the software center.

This shouldn't be a debate in my opinion. OnlyOffice should have been included in the repositories a long time ago.

at least it is availabe as snap:
http://www.onlyoffice.com/blog/2018/02/onlyoffice-desktop-editors-now-available-as-a-snap/

snap install onlyoffice-desktopeditors
snap run onlyoffice-desktopeditors
moriel5 added a subscriber: moriel5.May 5 2018, 8:34 PM

I just wanted to share my experiences with LibreOffice vs. WPS Office vs. OnlyOffice.
This is just a compilation of the most important aspects, time to open and the like, while very important, take a side seat to these.

Best compatibility with MS Office documents in Latin languages: OnlyOffice.
Best compatibility with MS Office documents which have Hebrew characters: LibreOffice.
(Subjective) Most comfortable UX (not talking about beauty): WPS Office.

This comment was removed by JoshStrobl.