Page MenuHomeSolus

Krita does not show image files in the file picker window.
Closed, ResolvedPublic

Description

Krita seems to be having an issue specific to Solus. When one attempts to open a new image (File > Open...), the file manager that opens will not display or list any .PNG or .JPG images. It will display folders and allow you to navigate around, but image files will not be listed, even with the File of Type option set as 'All supported formats'

However, if you are in the correct directory to where you know the files to be, manually typing in the name of the image file and pressing enter (or clicking Open) will open the file in Krita as normal.

Also, if you manipulate an image in Krita and then export/save it somewhere, Krita will display it in the file manager. It seems it is only capable of listing/displaying images it has directly saved.

Saving/exporting a file with the native Solus version of Krita will result in the Appimage version from the Krita website unable to see it, and visa versa.

Event Timeline

Can't reproduce issue.

Can't reproduce issue.

Hmm...Must be something just borked on my particular install. Not getting any errors when Krita is opened in a terminal either. Also didn't realize we could upload screenshots so...Might as well :P

I'm betting a reinstall might fix it, and I've been considering giving the MATE edition a try anyway :)

Yea I'm not saying there isn't an issue, I'm just saying I can't reproduce it. Is there anything worth noting if you run Krita from the Terminal?

Nothing jumps out to me, but I'd never opened it from the terminal until now, so I'm not sure what a normal start-up would look like.

Here's the output from starting Krita:

QCoreApplication::arguments: Please instantiate the QApplication object first
krita.lib.pigment: Compiled for arch: 1
krita.lib.pigment: Features supported:
krita.lib.pigment: 	 "SSE2" 	---	 yes
krita.lib.pigment: 	 "SSSE3" 	---	 no
krita.lib.pigment: 	 "SSE4.1" 	---	 no
krita.lib.pigment: 	 "AVX " 	---	 no
krita.lib.pigment: 	 "AVX2 " 	---	 no
Set style "fusion"
OpenGL Info
  Vendor:  X.Org
  Renderer:  Gallium 0.4 on AMD CAPE VERDE (DRM 2.46.0 / 4.8.4, LLVM 3.9.0)
  Version:  3.0 Mesa 13.1.0-devel
  Shading language:  1.30
  Requested format:  QSurfaceFormat(version 3.0, options QFlags(0x4), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 0, profile  2)
  Current format:    QSurfaceFormat(version 3.0, options QFlags(0x4), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 0, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 0, profile  0)
krita has opengl true
Setting XDG_DATA_DIRS "/usr/bin/../share:"
Available translations QSet("pa", "th", "cs", "tr", "pl", "nds", "cy", "he", "pt", "da", "hi", "de", "lt", "lv", "ug", "hr", "uk", "hu", "pt_BR", "ast", "en_GB", "zh_CN", "hne", "ia", "mk", "uz", "uz@cyrillic", "zh_TW", "mr", "ms", "is", "el", "vi", "it", "af", "eo", "nb", "es", "et", "eu", "ne", "ro", "ja", "ar", "nl", "ru", "nn", "fa", "wa", "ca@valencia", "fi", "be", "bg", "en_US", "se", "fr", "oc", "sk", "sl", "fy", "br", "bs", "sq", "sv", "ga", "kk", "km", "ca", "ko", "ta", "xh", "gl", "mai", "tg")
Available domain translations QSet("pa", "th", "cs", "tr", "pl", "nds", "cy", "he", "pt", "da", "hi", "de", "lt", "lv", "ug", "hr", "uk", "hu", "pt_BR", "ast", "en_GB", "zh_CN", "hne", "ia", "mk", "uz", "uz@cyrillic", "zh_TW", "mr", "ms", "is", "el", "vi", "it", "af", "eo", "nb", "es", "et", "eu", "ne", "ro", "ja", "ar", "nl", "ru", "nn", "fa", "wa", "ca@valencia", "fi", "be", "bg", "en_US", "se", "fr", "oc", "sk", "sl", "fy", "br", "bs", "sq", "sv", "ga", "kk", "km", "ca", "ko", "ta", "xh", "gl", "mai", "tg")
Override language: ""

Yea that didn't provide anything particularly useful, damn :D Looks fairly similar to mine (mine having different values for features supported but that is hardware stuff)

DataDrake moved this task from Backlog to Package Fixes on the Software board.Oct 31 2016, 8:07 PM

@Commander-Zal do you also have kdenlive installed? There were a couple of items I didn't build with krita (to reduce the long long dependency chain), but they ended up being used in kdenlive anyway...

@sunnyflunk That might explain it. I have both Krita and Kdenlive installed. Anything I can get you to help narrow it down or do you have an idea?

* KIO  <http://api.kde.org/frameworks-api/frameworks5-apidocs/kio/html/index.html>
  KDE's KIO Framework
  Optionally used for recent document handling
* kcrash  <http://api.kde.org/frameworks-api/frameworks5-apidocs/kcrash/html/index.html>
  KDE's Crash Handler
  Optionally used to provide crash reporting on Linux

My guess would be KIO, as that is the one that would deal with that kind of thing. (though kdenlive also pulls in kfilemetadata which would be my 2nd look).

Right, I'll start removing bits and checking.

Interestingly enough, removed both KIO and kfilemetadata and it still shows for me.

Commander-Zal added a comment.EditedOct 31 2016, 9:11 PM

@Commander-Zal do you also have kdenlive installed?

No, I have yet to install it on this machine. Echoing Josh, let me know if I can help at all :)

I have tested this now also and can't reproduce (with just krita installed).

It maybe you are having conflicts with the Appimage version given what you've said...

@Commander-Zal you could try moving this file and directory and starting the Solus version to see if that changes anything (and move them back after if you want to keep your settings).

~/.config/kritarc
~/.local/share/krita
Commander-Zal added a comment.EditedNov 1 2016, 1:19 AM

@sunnyflunk

No change, unfortunately.

For clarification, I only downloaded the Appimage version after encountering this issue with the Solus version (otherwise you're probably wondering why on earth I had both :P)

If neither of you can replicate it, I'm thinking it's localized to just my machine. I'd be willing to do a fresh reinstall to see if it pops back up again, or I can keep this install around for a while if you'd like me to try some other things.

Either way, I appreciate both your efforts. ^‿^

Done a fresh reinstall perchance @Commander-Zal ?

@JoshStrobl

Unfortunately I haven't been able to test that yet, as I've been trying out GeckoLinux on the desktop giving the issue with Krita. However, I did install Solus onto my Thinkpad X201 laptop, and Krita works normally there.

I'll be sure to leave an update here the next time I try Solus on the desktop, but you can probably tag this as resolved for now. :)

JoshStrobl closed this task as Resolved.Nov 15 2016, 5:53 AM
JoshStrobl claimed this task.

Thanks for letting me know :)