Page MenuHomeSolus

Torchlight 2 Startup Issue
Closed, ResolvedPublic

Description

Hey, there.

So, starting up Torchlight 2 (through native Steam) proves to be problematic. With the native runtime provided by the OS enabled (in Linux Steam Integration), the mod launcher hangs, remaining unresponsive and graphically not displaying properly.

With the native runtime option disabled, the mod launcher launches fine and the game can be run properly.

Running Solus 1.2.1 64-bit.

Event Timeline

SolarLune added a project: Software.
sunnyflunk triaged this task as Normal priority.Oct 27 2016, 9:38 PM
sunnyflunk added a subscriber: sunnyflunk.

A couple of issues are going on with this (I own the game so can test things easily). It includes a number of libs from OGRE and CEGIS and runs the usual LD_PATH="./lib64:$LD_PATH" to load the launcher.

The game seems to run if you can get past that screen (which doesn't load properly, but occasionally bugs out).

My look at it I thought that the combination of 1. libintercept implemented to LSI to defeat the LD_PATH. 2. And possibly then adding the OGRE, CEGIS libs to the Solus runtime would make it to work out of the box.

DataDrake moved this task from Backlog to Package Fixes on the Software board.Oct 28 2016, 8:36 PM
flgfish added a subscriber: flgfish.EditedMay 2 2017, 9:22 AM

I'm not sure if this is the right place or not, stumbled in here via Google. :)
I can't get Torchlight 2 to start on Linux, via Steam.
The Mod window gets created & I can see it in Gnome, but it's blank, and the game just hangs from there.
Not sure where to start debugging - happy to collect any information I can.

Running Fedora 25, nVidia GTX 670, Nouveau driver.

dim added a subscriber: dim.EditedMay 6 2017, 3:26 PM

My system is an up-to-date Solus GNOME 64-bit. I have Torchlight II (both Steam and GOG).

To run the GOG one I have to install libglu (a must-have) and libtxc_dxtn (optional, but highly recommended).

As for Steam verstion, I confirm the problem above. Moreover, every time I try to Torchlight II with Steam runtime, it starts to unpack its runtime thing.

May 08 00:38:12 solus steam.desktop[1769]: STEAM_RUNTIME is enabled by the user
May 08 00:38:12 solus steam.desktop[1769]: /home/dim/.local/share/Steam/steam.sh: line 338: cmp: command not found

steam.sh: line 338

	# Make sure we haven't already unpacked them
	if [ -f "$STEAM_RUNTIME/checksum" ] && cmp "$STEAM_RUNTIME.checksum" "$STEAM_RUNTIME/checksum" >/dev/null; then
		return 0
	fi

EDIT: cmp is in diffutils package which was not installed by default.

I can confirm that the issue persists with the latest nVidia binary driver, as well.

Ok, I was testing some runtime things and I discovered this appears to be due to something gnome, possibly libmutter (so broken on Gnome and Budgie 10). Launched without issue on MATE/Plasma

ikey closed this task as Resolved.Oct 11 2017, 4:37 PM
ikey claimed this task.
ikey added a subscriber: ikey.

Resolved in unstable with latest LSI & stack updates

This will be available on Friday's sync

FWIW my suspicion is the Steam Overlay was causing the issue, and Mutter was unable to handle it properly. Now Steam via LSI 0.4.1 has to use our libraries, and windowing stuff works
properly again.