Page MenuHomeSolus

Geierlein
Closed, InvalidPublic

Description

Name: Geierlein
Homepage: https://stesie.github.io/geierlein/
Open Source: yes
Source: https://github.com/stesie/geierlein
https://github.com/stesie/geierlein/archive/V0.9.5.tar.gz
Description: "Geierlein is a free (AGPL'ed) Elster client, i.e. an application that allows to send VAT declarations to Germany's fiscal authorities."

Details

Differential Revisions
D338: Initial commit of geierlein
nexus added a subscriber: nexus.Oct 19 2016, 6:21 AM

Just discovered this! Never heard of it before but as a fellow german i would like to use this on solus!

nexus awarded a token.Oct 19 2016, 6:21 AM

It is simply the best open source software for sending VAT declarations. No better alternative that I know of, so I requested this.

NeoVsk claimed this task.Nov 1 2016, 1:58 AM

I am presented with this error when I try to run the application. It seems that Solus are two versions ahead of the max version of Firefox that Geierlein supports.

Error: Platform version '50.0' is not compatible with
minVersion >= 3.5
maxVersion <= 48.*
JoshStrobl triaged this task as Normal priority.
JoshStrobl added a subscriber: JoshStrobl.

Looks like 0.9.13 supports Firefox 57 even, so moving to Accepted for Inclusion and out of Awaiting Package Upgrades. They seem to be keeping up with Firefox releases now.

DataDrake removed NeoVsk as the assignee of this task.Jun 16 2018, 11:55 PM
DataDrake added a subscriber: NeoVsk.
JoshStrobl closed this task as Wontfix.Jun 25 2018, 1:07 PM
JoshStrobl added a project: Needs Maintainer.
JoshStrobl claimed this task.

This has sat in accepted for inclusion for over a year. Clearly, there is a lack of demand for the inclusion of this software, nobody has stepped up to provide a patch, maintain it, and properly integrate it. Closing as a result. Feel free to reopen but only when someone offers a patch via our proper patch submission methods and volunteers to be maintainer.

Any German speakers around? I think this project is dead.

The github link now shows a notice which (when passed through machine translation) makes it sound like the project has shutdown because the German government has discontinued the API this program relied on.

German speakin, can confirm project will be dead

sunnyflunk changed the task status from Wontfix to Invalid.Nov 4 2018, 4:58 AM
sunnyflunk removed a project: Needs Maintainer.
sunnyflunk added a subscriber: sunnyflunk.

Based on that it will no longer work pretty shortly. This is no longer accepted for inclusion.

German speakin, can confirm project will be dead

Yes, confirmed. The bavarian regional authorities shuts the open interface and will only allow a closed source interface solution named "ERiC". So developer Stefan Siegl declares the project as dead.