Page MenuHomeSolus

Solus for academia
Closed, DuplicatePublic

Description

This is intended to be a parent task to get Solus ready for use in schools and universities. What general office, education and productivity tools are still missing to make Solus your sole operating system in academia?

  1. Add bibliographic tools and reference managers
  2. Add dictionaries and other language tools
  3. Add PDF tools capable of annotating and highlighting text
  4. Add virtual learning environments and teaching tools
  5. Add mind mapping, concept mapping and argument mapping tools
  6. Add spaced-repetition software and other flash card memorization tools
  7. Add time and task management related apps

Related Objects

StatusAssignedTask
DuplicateNone
ResolvedNone
WontfixDataDrake
ResolvedDataDrake
WontfixJoshStrobl
WontfixJoshStrobl
WontfixJoshStrobl
WontfixDataDrake
WontfixDataDrake
WontfixJoshStrobl

I'm seriously in 2 minds about this. Solus is a home OS, not an education OS.

baimafeima added a comment.EditedOct 11 2016, 8:25 AM

"Home" is a very broad term. I like this comprehensive approach a lot. Niche distros like Scientific Linux or the now discontinued Edubuntu are intended for a special user base. I was really just thinking of general tools that any student or teacher would use in a "home" Windows or Mac OS environment. I don't see why including these tools would make Solus in any way an education OS. Solus is good as it is. Many of these tools are necessary to increase Solus user adoption among students and lecturers and increase productivity in a comprehensive home OS :)

DataDrake updated the task description. (Show Details)Oct 11 2016, 10:14 AM
  1. We already have pomodoro
  2. I don't understand the need for this task. It's clear that most of the listed subtasks have already been approved for inclusion.
  3. I agree that some of these tools are generally useful for learning and could be used to that end in academia, but if anything most of these applications fall under the category of office and productivity apps.
JoshStrobl closed this task as a duplicate of T249: Education software.Oct 11 2016, 10:20 AM
JoshStrobl added a subscriber: JoshStrobl.

Closing as a dup of T249, educational software. Necessary additions of educational software could be requested there, though they should really be requested separately, as per our policy.

To elaborate further, most of the application types you're requested, we already cover. @DataDrake remarked about pomodoro, we also provide dictionary applications, mind-mapping software has been requested, educational software already added, PDF tools requested, etc.

There really is no need for this task.

JoshStrobl changed the edit policy from "All Users" to "Triage Team (Project)".Oct 11 2016, 10:24 AM
JoshStrobl changed the status of subtask T640: Foxit Reader from Open to In Progress.Oct 22 2016, 8:46 PM
DataDrake closed subtask T957: Syng as Wontfix.Oct 28 2016, 7:15 PM
DataDrake closed subtask T638: Docear as Wontfix.Nov 5 2016, 7:51 PM
JoshStrobl closed subtask T685: Zotero as Wontfix.Jun 25 2018, 1:10 PM
DataDrake closed subtask T957: Syng as Wontfix.Jul 29 2018, 3:08 PM