Page MenuHomeSolus

Telegram Desktop
Closed, ResolvedPublic

Description

I'm trying to start Telegram without success on Plasma ( fresh install )

the log

[2022.04.30 00:04:34] Launched version: 3007000, install beta: [FALSE], alpha: 0, debug mode: [FALSE]
[2022.04.30 00:04:34] Executable dir: /usr/bin/, name: telegram-desktop
[2022.04.30 00:04:34] Initial working dir: /home/cybernet/
[2022.04.30 00:04:34] Working dir: /home/cybernet/.local/share/TelegramDesktop/
[2022.04.30 00:04:34] Command line: telegram-desktop --debug
[2022.04.30 00:04:34] Executable path before check: /usr/bin/telegram-desktop
[2022.04.30 00:04:34] Logs started
[2022.04.30 00:04:34] Launcher filename: telegramdesktop.desktop
[2022.04.30 00:04:34] IBus portal is present! Using it.
[2022.04.30 00:04:34] Getting DE, XDG_CURRENT_DESKTOP: 'KDE'
[2022.04.30 00:04:34] Getting DE, XDG_SESSION_DESKTOP: 'KDE'
[2022.04.30 00:04:34] Getting DE, DESKTOP_SESSION: '/usr/share/xsessions/plasma'
[2022.04.30 00:04:34] Getting DE via WM: 'KWin'
[2022.04.30 00:04:34] Getting DE, GNOME_DESKTOP_SESSION_ID: ''
[2022.04.30 00:04:34] Getting DE, KDE_FULL_SESSION: 'true'
[2022.04.30 00:04:34] DE: KDE
[2022.04.30 00:04:34] Connecting local socket to /run/user/1000/0dc31b99f548aabdc3e774f343950a47-{87A94AB0-E370-4cde-98D3-ACC110C5967D}...
[2022.04.30 00:04:34] Socket connect error 0, starting server and app...
[2022.04.30 00:04:34] Moved logging from '/home/cybernet/.local/share/TelegramDesktop/log_start0.txt' to '/home/cybernet/.local/share/TelegramDesktop/log.txt'!
[2022.04.30 00:04:34] Primary screen DPI: 96
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAOpenSansRegular.ttf' loaded 'DAOpenSansRegular'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAVazirRegular.ttf' loaded 'DAVazirRegular'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAOpenSansRegularItalic.ttf' loaded 'DAOpenSansRegularItalic'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAVazirRegular.ttf' loaded 'DAVazirRegular'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAOpenSansSemiboldAsBold.ttf' loaded 'DAOpenSansSemibold'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAVazirMediumAsBold.ttf' loaded 'DAVazirMedium'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAOpenSansSemiboldItalicAsBold.ttf' loaded 'DAOpenSansSemiboldItalic'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAVazirMediumAsBold.ttf' loaded 'DAVazirMedium'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAOpenSansSemiboldAsBold.ttf' loaded 'DAOpenSansSemibold'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAVazirMediumAsBold.ttf' loaded 'DAVazirMedium'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAOpenSansSemiboldItalicAsBold.ttf' loaded 'DAOpenSansSemiboldItalic'
[2022.04.30 00:04:34] Font: from ':/gui/fonts/DAVazirMediumAsBold.ttf' loaded 'DAVazirMedium'
[2022.04.30 00:04:34] Icon theme: breeze-dark
[2022.04.30 00:04:34] Fallback icon theme: breeze
[2022.04.30 00:04:34] Assertion Failed! "index < _sprites.size()" emoji_config.cpp:447

any help is appreciated

Event Timeline

livingsilver94 added a subscriber: livingsilver94.EditedApr 30 2022, 8:05 AM

Could you please try to install qt6-imageformats and see if that solves the issue?

livingsilver94 added a comment.EditedApr 30 2022, 8:06 AM

Also, Please use the Software tag if you installed telegram from our repository. Third Party Software is for a legacy mechanism for installing closed source applications.

cybernet2u closed this task as Resolved.Apr 30 2022, 8:58 AM
cybernet2u claimed this task.
cybernet2u edited projects, added Software; removed Third Party Software.

thanks a lot !
that did solve the issue.
iMO it should be added as a dependency
cheers

Yes indeed! That's the plan. I wonder why I don't have that package installed yet my telegram works...

algent added a subscriber: algent.Apr 30 2022, 10:37 AM

Yes indeed! That's the plan. I wonder why I don't have that package installed yet my telegram works...

I don't have it installed too, and Telegram works fine.

I thought this was supposed to be a professional “debate” or “chat”
It appears to be that on Budgie works without that package. it has something to do with KDE … at least for me

@cybernet2u what packages have been installed when you installed qt6-imageformats? If you don't remember, you can check them via eopkg history.

just that. but I remember seeing when I was updating, multiple qt6-* packages being updated. most likely there were included in the base installation.
i’ll check tonight the history and post a pastebin here

For now I added qt6-imageformats to the deps, since it surely doesn't hurt. Should we discover something more, I'll submit another patch.

Staudey added a subscriber: Staudey.May 1 2022, 5:28 PM

I just checked in a clean Solus Plasma VM and get the same error. Installing qt6-imageformats fixes it. It's the only package that gets installed.