Page MenuHomeSolus

OpenCL support for AMD GPU/APU
Closed, DuplicatePublic

Description

I installed Blackmagic Design DaVinci Resolve 17 Studio on my Laptop with an AMD Ryzen 7 4800H with Radeon Graphics.

Installation was fine but it needs GPU processing with OpenCL 1.2 or CUDA 11. The later is exclusive to Nvidia GPUs but OpenCL 1.2 should work with my AMD GPU.

According to davidjharder in the Solus forum, Solus does not have OpenCL support for AMD GPUs ... please add it.

Event Timeline

chris109 created this task.Dec 7 2021, 9:11 AM

I followed the links and didn't understand anything ...

Is there OpenCL 1.2 support with AMD GPUs or not?

  • If YES, what package do I need to install?
  • If NO, how long will it take to make it available?

I followed the links and didn't understand anything ...
Is there OpenCL 1.2 support with AMD GPUs or not?

  • If YES, what package do I need to install?
  • If NO, how long will it take to make it available?

I'll make it easier.
OpenCL support is only supported via the AMDGPUPro proprietary driver, needed for proper OpenCL detection. https://dev.getsol.us/T3147#165253
However, per AMD EULA terms, they can't repackage it for the Solus distribution. https://dev.getsol.us/T6614#119454

An another alternative, to make it work, would be to be able to build the ROCm interface which has already have been able to be built and use, as said here https://dev.getsol.us/T6614#121162 but it is pretty difficult to build, and prone to break during the build[[ URL | (And I've did tried) ]].
Current works, outside of @DataDrake attempts, on making a ROCm package for Solus seems to be done by the community here.
They know that's a bummer, and i had to switch to Fedora due to that, and the ability to switch to the proprietary drivers.

Thank you for clarification. - So it's not there but it's being worked on (which is difficult).

As far as I've read the AMDGPUPro proprietary driver is no option, because gaming would suffer with this driver ... and there is the license issue of corse.

So ROCm is the way to go?

How long might it take?

I'd love to try, if DaVinci Resolve will work with it ...

Thank you for clarification. - So it's not there but it's being worked on (which is difficult).
As far as I've read the AMDGPUPro proprietary driver is no option, because gaming would suffer with this driver ... and there is the license issue of corse.
So ROCm is the way to go?
How long might it take?
I'd love to try, if DaVinci Resolve will work with it ...

The main reason is just because it can't be re-distributed. Not because it isn't "gaming performance friendly".
In theory, from several who managed to make it work, this should indeed allow DaVinci Resolve to work with the GPU on Solus.
However, you may try it from the previous GitHub community repo previously shared, but it ain't ready.
You can't set an estimated timeline on such obstacle to surpass.

JoshStrobl closed this task as a duplicate of T6614: OpenCL AMD Driver.Dec 8 2021, 4:19 PM