Page MenuHomeSolus

openssl still depends on cppzmq-devel rather than cppzmq
Closed, InvalidPublic

Description

Extracting the files of openssl-11-devel
Installed openssl-11-devel
[✓] Syncing filesystems success
[✓] Updating dynamic library cache success

  • Updating clr-boot-manager skipped
  • Updating clr-boot-manager skipped
  • Registering QoL migration on next boot skipped
  • Reloading systemd configuration skipped
  • Re-starting vendor-enabled .socket units skipped
  • Re-executing systemd skipped
  • Reloading udev rules skipped
  • Reloading udev rules skipped

[BuildDep] Checking build-deps for horizon-eda-2.1.0-1
[BuildDep] Unknown build deps: cppzmq-devel
ERRO[10:27:06] Failed to install build dependencies buildFile="/home/build/work/package.yml" error="exit status 1"

Seems similar to: https://dev.getsol.us/D12192

Discovered while trying to build package (sudo solbuild build) from: https://dev.getsol.us/file/data/msh7dksf2iczwe23qrjl/PHID-FILE-2nrrvw75lf7s2y4pwzzh/package.yml which is just some package I found while searching an example package.yml file.
ERRO[10:27:08] Failed to build packages

Event Timeline

dufresnep created this task.Nov 6 2021, 2:54 PM
algent added a subscriber: algent.EditedNov 6 2021, 3:10 PM

Hi @dufresnep .

The problem is with horizon-eda package.yml file.
Replace there cppzmq-devel with cppzmq and it will be fine.

I commented here https://dev.getsol.us/D12153 also, to notify the maintaner to do the same.

JoshStrobl closed this task as Invalid.Nov 6 2021, 8:55 PM