Page MenuHomeSolus

Kernel 5.14.15 renders laptop unresponsive
Closed, ResolvedPublic

Tokens
"Hungry Hippo" token, awarded by kyrios123."100" token, awarded by fernkaufmann."Like" token, awarded by Niobleoum."The World Burns" token, awarded by Staudey."100" token, awarded by ReillyBrogan."Dat Boi" token, awarded by joebonrichie."Party Time" token, awarded by livingsilver94."Party Time" token, awarded by davidjharder.
Assigned To
Authored By
joluveba, Nov 3 2021

Description

Since the last update to kernel 5.14.15, booting takes a long time in my Asus laptop. It prompts for kdewallet password. Afterwards, it becomes unresponsive. If I boot into the previous kernel 5.14.14, the laptop works as usual.

Asus Vivobook
CPU AMD Ryzen 5 3500U
GPU AMD Radeon Vega 8
Solus Plasma

Others users have reported the same problem, these are their computer data:

Lenovo Ideapad 3 LNVB161216
Ryzen 5 3500U
Radeon Vega Mobile GFX
Solus Plasma

AMD Ryzen 3 3200G
AMD Vega 8 Graphics
Solus Budgie

I have another computer with CPU Intel and GPU Nvidia that works as expected under kernel 5.14.15

Thank you in advance, kind regards

Event Timeline

joluveba created this task.Nov 3 2021, 8:21 PM

The problem occurs as well with following hardware:

ASUS TUF Gaming FX505DT
CPU: AMD Ryzen 5 3550H
GPU: Nvidia GTX 1650
Budgie / Plasma (checked both editions)

Same for me:

CPU/GPU AMD Ryzen5 3400G
Budgie

Funfact: The Kernel before delivered the best performance ever on this setup.

JoshStrobl triaged this task as Normal priority.Nov 4 2021, 7:31 PM
JoshStrobl edited projects, added Hardware, Software; removed Lacks Project.
JoshStrobl added a subscriber: JoshStrobl.

I have updated our kernel to 5.14.16, which features multiple changes for drm/amd/display and drm/amdgpu. If you are unstable, the update is available now. If you are on stable, this will be pushed on Friday. Not marking as resolved, however if it isn't resolved beyond these changes I would encourage you to file an issue at https://gitlab.freedesktop.org/drm/amd/-/issues so it can be triaged and addressed upstream by the folks responsible for the development and support of this hardware in the kernel.

zmaint added a subscriber: zmaint.EditedNov 5 2021, 4:36 PM

Just updated to the new kernel and the issue is the same. Booting from 5.14.14-202.current works fine.

I'm the Lenovo Ideapad 3 in the OP.

Opened an issue here: https://gitlab.freedesktop.org/drm/amd/-/issues/1777

zmaint added a comment.Nov 5 2021, 7:47 PM

They said to please make sure the kernel has this patch.

commit afd18180c07026f94a80ff024acef5f4159084a4
Author: Yifan Zhang <yifan1.zhang@amd.com>
Date: Mon Oct 11 20:37:01 2021 +0800

drm/amdkfd: fix boot failure when iommu is disabled in Picasso.

When IOMMU disabled in sbios and kfd in iommuv2 path, iommuv2
init will fail. But this failure should not block amdgpu driver init.

Reported-by: youling <youling257@gmail.com>
Tested-by: youling <youling257@gmail.com>
Signed-off-by: Yifan Zhang <yifan1.zhang@amd.com>
Reviewed-by: James Zhu <James.Zhu@amd.com>
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>

They said to please make sure the kernel has this patch.
commit afd18180c07026f94a80ff024acef5f4159084a4
Author: Yifan Zhang <yifan1.zhang@amd.com>
Date: Mon Oct 11 20:37:01 2021 +0800

drm/amdkfd: fix boot failure when iommu is disabled in Picasso.
When IOMMU disabled in sbios and kfd in iommuv2 path, iommuv2
init will fail. But this failure should not block amdgpu driver init.
Reported-by: youling <youling257@gmail.com>
Tested-by: youling <youling257@gmail.com>
Signed-off-by: Yifan Zhang <yifan1.zhang@amd.com>
Reviewed-by: James Zhu <James.Zhu@amd.com>
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>

Looks like that patch is going to be in 5.14.17. It should also be in 5.15.1 if we end up switching to that first. It may also end up getting pulled in manually if Josh decides he wants to hotfix this issue.

zmaint added a comment.Nov 5 2021, 8:31 PM

Thank you much appreciated. I'm ok sticking with the older kernel until the next update whenever that comes.

@zmaint I have backported that patch to our 5.14.16. Assuming you are not using any supplemental kernel modules (e.g. bbswitch, broadcom-sta, nvidia proprietary drivers, virtualbox, etc.) you can use the following instructions to install it. If you are using the unstable repo, then you can upgrade as normal to test.

sudo eopkg install https://mirrors.rit.edu/solus/packages/unstable/l/linux-current/linux-current-5.14.16-205-1-x86_64.eopkg

If you are using any supplemental kernel modules, I would suggest waiting until all the rebuilds are done (per https://build.getsol.us, everything leading up to and including virtualbox) and testing a bit after those are built. If you aren't on unstable, you can temporarily switch to it by running: sudo eopkg ar Solus https://mirrors.rit.edu/solus/packages/unstable/eopkg-index.xml.xz and after upgrading, do: sudo eopkg rr Solus && sudo eopkg ur which will remove the current Solus repo (unstable), and the update-repo will force the Solus stable repo to be re-added.

If the testing works out, I'll push it to stable, otherwise I won't bother (since it'd be an otherwise pointless update).

zmaint added a comment.Nov 6 2021, 1:33 PM

It's a straight up AMD, I only use it for work so no virtualbox or any other kernel add-ons.

Ran updates as normal (I had rolled back to the last working kernel), then rebooted, verified it was still running like crap. Got a terminal and installed the patched kernel as directed. Rebooted and everything is back to normal. System is now all up to date and working smoothly.

Thank you, much appreciated!

No problem. Will get it deployed to stable repo shortly.

JoshStrobl closed this task as Resolved.Nov 6 2021, 5:05 PM
JoshStrobl claimed this task.

Evidently folks opted to push packages after the kernel, so it is going to have to wait. Bunch of stuff needing testing in unstable now.

Going to mark this as resolved though.

I did as Joshua Strobl suggested. I switched to unstable, updated, and managed to boot successfully with kernel 5.14-16-205 (the one with the patch), and then switched back to stable. Glad to see it worked! Thank you JoshStrobl and zmaint for your help!