HomeSolus

gstreamer-1.0-plugins-bad: switch from libmodplug to libopenmpt

Authored by aleksvor on Apr 25 2021, 10:47 AM.

Description

gstreamer-1.0-plugins-bad: switch from libmodplug to libopenmpt

Summary:
Switch from libmodplug to libopenmpt for support of MOD files. The reasons for preferring libopenmpt are detailed in T9550.
Depends on D10907.

Test Plan:
Played back 2 MOD files (FastTracker2 and ProTrackerMOD) using GStreamer pipeline:
gst-launch-1.0 -v filesrc location=hard_day.mod ! decodebin ! audioconvert ! audioresample ! pulsesink
gst-launch-1.0 -v filesrc location=okavango.xm ! decodebin ! audioconvert ! audioresample ! pulsesink

Reviewers: Triage Team, JoshStrobl

Reviewed By: Triage Team, JoshStrobl

Subscribers: JoshStrobl

Differential Revision: https://dev.getsol.us/D10915