Page MenuHomeSolus

Update to 4.0.3
Needs ReviewPublic

Authored by kevindkeogh on Oct 8 2020, 3:44 PM.

Details

Reviewers
DataDrake
Group Reviewers
Triage Team
Summary

Changelog here

Test Plan

Ran R --version in terminal
Ran install.packages("tidyverse")
Tested a few simple computations (e.g., 2+2) and linear regressions

Diff Detail

Repository
R2778 r
Branch
master
Lint
No Linters Available
Unit
No Unit Test Coverage

Event Timeline

kevindkeogh created this revision.Oct 8 2020, 3:44 PM
kevindkeogh requested review of this revision.Oct 8 2020, 3:44 PM
kevindkeogh updated this revision to Diff 24261.Dec 5 2020, 5:35 PM

Update r to 4.0.3, and use the pkgconfig(pcre2-posix) instead of libpcre-devel package

kevindkeogh retitled this revision from Update to 4.0.2 to Update to 4.0.3.Dec 5 2020, 5:52 PM
kevindkeogh edited the test plan for this revision. (Show Details)
DataDrake accepted this revision.Dec 15 2020, 9:58 AM
DataDrake added a subscriber: DataDrake.

LGTM. Thanks!

This revision is now accepted and ready to land.Dec 15 2020, 9:58 AM
DataDrake requested changes to this revision.Dec 15 2020, 10:08 AM

I'm seeing a lot of local changes to abi_used_libs did you forget to commit them?

This revision now requires changes to proceed.Dec 15 2020, 10:08 AM

Rebuilt using make, which includes a few updates (including abi_used_libs).

DataDrake requested changes to this revision.Dec 16 2020, 9:36 AM

I checked locally and it looks like these are no longer needed:

  • pkgconfig(com_err)
  • pkgconfig(krb5)
  • pkgconfig(libnghttp2)
  • pkgconfig(libssh2)

IIRC this is a hold-over from when it was fixed in libcurl.

This revision now requires changes to proceed.Dec 16 2020, 9:36 AM

Removed libraries that are no longer needed, per DataDrake's suggestion