Page MenuHomeSolus

Remove python2 support from python-pickleshare
ClosedPublic

Authored by algent on Tue, Jul 21, 1:04 PM.

Details

Summary

This package is required only by spyder3. Python2 support not necessary after deprecation of spyder.

Signed-off-by: Algent Albrahimi <algent@protonmail.com>

Test Plan
  • Run a few python scripts using spyder3.
  • Run example script
>>> from pickleshare import *
>>> db = PickleShareDB('~/testpickleshare')
>>> db.clear()
>>> print("Should be empty:", db.items())
Should be empty: ItemsView(PickleShareDB('/home/algent/testpickleshare'))
>>> db['hello'] = 15
>>> db['aku ankka'] = [1,2,313]
>>> db['paths/are/ok/key'] = [1,(5,46)]
>>> print(db.keys())
['aku ankka', 'hello', 'paths/are/ok/key']
>>>

Diff Detail

Repository
R3693 python-pickleshare
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

algent created this revision.Tue, Jul 21, 1:04 PM
algent requested review of this revision.Tue, Jul 21, 1:04 PM
JoshStrobl accepted this revision.Wed, Jul 22, 8:30 AM
JoshStrobl added a subscriber: JoshStrobl.

LGTM, thanks!

This revision is now accepted and ready to land.Wed, Jul 22, 8:30 AM
This revision was automatically updated to reflect the committed changes.