Page MenuHomeSolus

Downgrade python-spyder-kernels to version 0.5.2
ClosedPublic

Authored by algent on Mon, Jul 20, 10:43 PM.

Details

Summary

Newest version after 0.5.2 are for spyder3 version 4 series. Using them now breaks our spyder3 wich is still on version 3 series.

Signed-off-by: Algent Albrahimi <algent@protonmail.com>

Test Plan

Run some example scripts on spyder3.

Diff Detail

Repository
R4473 python-spyder-kernels
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

algent created this revision.Mon, Jul 20, 10:43 PM
algent requested review of this revision.Mon, Jul 20, 10:43 PM

@kyrios123 can you take a look at this since you were the last one to update this? Was your update properly tested against spyder3?

algent retitled this revision from Revert python-spyder-kernels to version 0.5.2 to Downgrade python-spyder-kernels to version 0.5.2.Tue, Jul 21, 10:40 AM

If it was tested against spyder3, @algent could you elaborate on what specific issue you're getting?

algent added a comment.EditedTue, Jul 21, 11:14 AM

Just to make sure, started over and reinstalled spyder3, also reset it from terminal

spyder3 --reset

and then run it again:

$ spyder3
Traceback (most recent call last):
  File "/usr/bin/spyder3", line 3, in <module>
    start.main()
  File "/usr/lib/python3.7/site-packages/spyder/app/start.py", line 178, in main
    from spyder.app import mainwindow
  File "/usr/lib/python3.7/site-packages/spyder/app/mainwindow.py", line 49, in <module>
    requirements.check_spyder_kernels()
  File "/usr/lib/python3.7/site-packages/spyder/requirements.py", line 66, in check_spyder_kernels
    % actual_ver)
  File "/usr/lib/python3.7/site-packages/spyder/requirements.py", line 24, in show_warning
    raise RuntimeError(message)
RuntimeError: Please check Spyder installation requirements:
spyder-kernels < 1.0 is required (found 1.9.1).

Aparently this downgrade is not enough. A new package should be added python-backcall and python-prompt-toolkit should be updated to 3.0.5. Both are rundeps of python3-ipython.

I have those diffs ready.

JoshStrobl accepted this revision.Wed, Jul 22, 8:19 AM

Thanks for providing the error and patch. LGTM.

This revision is now accepted and ready to land.Wed, Jul 22, 8:19 AM
This revision was automatically updated to reflect the committed changes.

I am still facing issue with the latest spyder3 / spyder-kernels.
I tried with the latest numpy locally but it didn't help.

Traceback (most recent call last):
  File "/usr/bin/spyder3", line 3, in <module>
    start.main()
  File "/usr/lib/python3.7/site-packages/spyder/app/start.py", line 204, in main
    mainwindow.main()
  File "/usr/lib/python3.7/site-packages/spyder/app/mainwindow.py", line 3763, in main
    mainwindow = run_spyder(app, options, args)
  File "/usr/lib/python3.7/site-packages/spyder/app/mainwindow.py", line 3638, in run_spyder
    main.setup()
  File "/usr/lib/python3.7/site-packages/spyder/app/mainwindow.py", line 843, in setup
    from spyder.plugins.console.plugin import Console
  File "/usr/lib/python3.7/site-packages/spyder/plugins/console/plugin.py", line 29, in <module>
    from spyder.utils.environ import EnvDialog
  File "/usr/lib/python3.7/site-packages/spyder/utils/environ.py", line 19, in <module>
    from spyder.plugins.variableexplorer.widgets.collectionseditor import (
  File "/usr/lib/python3.7/site-packages/spyder/plugins/variableexplorer/widgets/collectionseditor.py", line 39, in <module>
    from spyder_kernels.utils.nsview import (
ImportError: cannot import name 'NUMERIC_NUMPY_TYPES' from 'spyder_kernels.utils.nsview' (/usr/lib/python3.7/site-packages/spyder_kernels/utils/nsview.py)

What version of spyder3 are you using here?

@kyrios123 spyder3 is running fine in my PC.

I tested it again now by removing it from my system also other packages like thonny that share some dependencies.
Reboot and install it again. 202 packages were installed. Deleted .config files and then start it again from terminal.
I don't see any error, except this Attribute Qt::AA_UseSoftwareOpenGL must be set before QCoreApplication is created..
Run some scripts and everything is fine.

What version of spyder3 are you using here?

spyder : v4.1.4 and spyder-kernels v1.9.1
Two new packages are required : diff-match-patch-python (v20200713) and intervaltree (v3.0.2)