Page MenuHomeSolus

Update ansible to 2.4.0.0 to address CVE-2017-7481
ClosedPublic

Authored by mcritchlow on Aug 15 2017, 3:44 AM.

Details

Summary

Full changelog

Package Update:

  • add asciidoc build dependency for docs
  • add python-jinja as build dependency
Test Plan
  • Local install
  • Confirmed version
  • Confirmed man docs generated and available
  • Tested local project using ansible-playbook and ansible commands

Diff Detail

Repository
R360 ansible
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
mcritchlow created this revision.Aug 15 2017, 3:44 AM
JoshStrobl requested changes to this revision.Aug 28 2017, 2:01 AM
JoshStrobl added a subscriber: JoshStrobl.

add asciidoc build dependency for docs

And what changed in the release?

This revision now requires changes to proceed.Aug 28 2017, 2:01 AM
mcritchlow edited the summary of this revision. (Show Details)Sep 21 2017, 2:41 PM

Sorry, work got busy and I haven't had time to properly do this. That said, 2.4.0 is out now with that patch merged upstream. While I haven't updated the Solus version to that and tested locally, that version has been running some of my projects/roles in Travis the last couple days with no hiccups. Any concerns about me just bumping to that version and testing?

Yeah, update it to 2.4.0, test and I'll merge it asap

mcritchlow updated this revision to Diff 2668.Sep 29 2017, 2:24 AM
mcritchlow edited edge metadata.

updated to 2.4.0.0

mcritchlow retitled this revision from update ansible to 2.3.2.0 to update ansible to 2.4.0.0.Sep 29 2017, 2:26 AM
mcritchlow edited the summary of this revision. (Show Details)
sunnyflunk retitled this revision from update ansible to 2.4.0.0 to Update ansible to 2.4.0.0 to address CVE-2017-7481.Oct 3 2017, 2:43 AM
sunnyflunk edited the summary of this revision. (Show Details)
This revision was automatically updated to reflect the committed changes.