Page MenuHomeSolus

Update python-gtts to 2.0.3
ClosedPublic

Authored by livingsilver94 on Aug 14 2019, 9:25 AM.

Details

Summary

Changelog

  • Added new tokenizer case for ':' preventing cut in the middle of a time notation
  • Added Python 3.7 support
  • Fixed language retrieval/validation broken from new Google Translate page
  • Fixed an UnicodeDecodeError when installing gTTS if system locale was not utf-8
  • Improved documentation

Package changes
Add missing dependencies.

Test Plan

Mycroft is working.

Diff Detail

Repository
R4375 python-gtts
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

livingsilver94 created this revision.Aug 14 2019, 9:25 AM
livingsilver94 requested review of this revision.Aug 14 2019, 9:25 AM
livingsilver94 edited the summary of this revision. (Show Details)Aug 15 2019, 6:48 PM
livingsilver94 retitled this revision from Add missing dependencies to Update python-gtts to 2.0.3.

Update package

Remove useless sed command

bs4 -> beautifulsoup4

JoshStrobl requested changes to this revision.Aug 23 2019, 1:16 PM
JoshStrobl added a subscriber: JoshStrobl.

There's like 5 items in the changelog. Otherwise LGTM.

This revision now requires changes to proceed.Aug 23 2019, 1:16 PM
livingsilver94 edited the summary of this revision. (Show Details)Aug 23 2019, 1:19 PM
JoshStrobl accepted this revision.Aug 23 2019, 2:38 PM
This revision is now accepted and ready to land.Aug 23 2019, 2:38 PM
This revision was automatically updated to reflect the committed changes.