Page MenuHomeSolus

Update qelectrotech to 0.61
ClosedPublic

Authored by Alexander88207 on Mon, Mar 25, 8:24 PM.

Details

Summary
Test Plan

Created a project, saved and reopened it.

Solves: T7759

Diff Detail

Repository
R3737 qelectrotech
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
Alexander88207 created this revision.Mon, Mar 25, 8:24 PM
Alexander88207 requested review of this revision.Mon, Mar 25, 8:24 PM
kyrios123 requested changes to this revision.Mon, Mar 25, 8:36 PM
kyrios123 added a subscriber: kyrios123.
kyrios123 added inline comments.
package.yml
5–6

Please update to use SPDX 3.x license identifier. It should be GPL-2.0-or-later

Also while updating the package also use the https link for the source.

Thanks :)

This revision now requires changes to proceed.Mon, Mar 25, 8:36 PM
kyrios123 added inline comments.Mon, Mar 25, 8:39 PM
package.yml
10–11

Not necessary

10–11

Not necessary

Fixed license & removed 2 uncessary builddeps

Girtablulu added inline comments.
package.yml
10–11

not needed due rev deps

10–11

is the same package as Qt5Core

10–11

qt5 base package, rev deps

11

qt5 base package, rev deps

12–13

qt5 base package, rev deps

12–13

qt5 base package,rev deps

Update builddeps again

Girtablulu added a comment.EditedMon, Mar 25, 9:29 PM

no that's wrong again :)

only builddep you need is

- pkgconfig(Qt5Svg)

this pulls in qt5-base-devel as well and qt5-base-devel provides all the old builddeps

kyrios123 added a comment.EditedMon, Mar 25, 10:04 PM

this pulls in qt5-base-devel as well and qt5-base-devel provides all the old builddeps

I'll call you @sunnyflunk2 now 😆

DataDrake accepted this revision.Sat, Mar 30, 9:55 PM
DataDrake added a subscriber: DataDrake.

LGTM. Thanks!

This revision was not accepted when it landed; it landed in state Needs Review.Sat, Mar 30, 10:00 PM
This revision was automatically updated to reflect the committed changes.