Page MenuHomeSolus

Update python-qt5 to 5.12.1
ClosedPublic

Authored by BridouZ on Mar 7 2019, 7:44 AM.

Details

Summary

Changelog:

  • Updated to 5.12.1
  • Removed pkgconfig(Qt5WebEngine) from builddeps
  • Changelog is here
Test Plan
  • Install OK
  • Build python3-qt5 against it OK
  • Tested against spyder and calibre, OK

Diff Detail

Repository
R2679 python-qt5
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

BridouZ created this revision.Mar 7 2019, 7:44 AM
BridouZ requested review of this revision.Mar 7 2019, 7:44 AM

There is now a version 5.12.1 and did you look into packaging the separation of PyQtWebEngine?

BridouZ updated this revision to Diff 13955.EditedMar 20 2019, 9:45 PM

Bump to 5.12.1, ping @Girtablulu ;)

BridouZ retitled this revision from Update python-qt5 to 5.12 to Update python-qt5 to 5.12.1.Mar 20 2019, 9:46 PM
BridouZ edited the summary of this revision. (Show Details)

cheers, trying to get this in ASAP is a little blocker for me for QT 5.12.2

Girtablulu added inline comments.Mar 20 2019, 9:56 PM
package.yml
20–21

Due the moved the webengine stuff into another package, this one is nor needed anymore

cheers, trying to get this in ASAP is a little blocker for me for QT 5.12.2

Why is this a blocker for QT 5.12.2, it already fully supports this version

2019-03-17 Phil Thompson <phil@riverbankcomputing.com>

  • PyQt5.msp: Updated for Qt v5.12.2. [71df8ce4b154] <5.12-maint>
BridouZ updated this revision to Diff 13970.Mar 21 2019, 6:39 PM

Removed QTWebEngine as builddep

BridouZ edited the summary of this revision. (Show Details)Mar 21 2019, 6:40 PM
BridouZ edited the summary of this revision. (Show Details)

Sorry but you have to rebase it, I had to rebuild it for QT 5.12.2 stack update

BridouZ updated this revision to Diff 14081.Mar 25 2019, 5:46 PM

Rebase on QT5.12.2

Could you please test this against spyder and calibre to make sure other application are working as well besides qutebrowser

Girtablulu requested changes to this revision.Mar 30 2019, 10:52 PM
This revision now requires changes to proceed.Mar 30 2019, 10:52 PM
BridouZ edited the test plan for this revision. (Show Details)Apr 1 2019, 12:09 PM

This will have to be rebuild against D6092

BridouZ updated this revision to Diff 14680.Apr 23 2019, 10:54 AM

Rebuild against (local) D6092

JoshStrobl accepted this revision.Apr 29 2019, 7:06 PM
JoshStrobl added a subscriber: JoshStrobl.

@kyrios123 if you could land this when you land your python sip package, that'd be appreciated

JoshStrobl requested changes to this revision.Apr 29 2019, 7:07 PM

Correction, do not land this.

@BridouZ are you sure you know how to do rebases? Because this isn't rebased.

This revision now requires changes to proceed.Apr 29 2019, 7:07 PM
BridouZ updated this revision to Diff 14831.Apr 30 2019, 6:25 AM

Rebase on master

Sorry for missed attempts

JoshStrobl accepted this revision.May 7 2019, 2:39 PM

I'll land it when I push the QT Update

This revision was not accepted when it landed; it landed in state Needs Review.May 7 2019, 2:52 PM
Closed by commit R2679:2bbbe280cb66: Update python-qt5 to 5.12.1 (authored by BridouZ, committed by Girtablulu). · Explain Why
This revision was automatically updated to reflect the committed changes.