Page MenuHomeSolus

Update qtractor to 0.9.3
ClosedPublic

Authored by Alexander88207 on Jan 3 2019, 9:18 PM.

Details

Summary

Changelog:

  • Auto-backward now skips the end-of-session location.
  • Audio clip time-stretching and pitch-shifting limits are now 10-fold in either direction.
  • Custom color (palette) theme editor introduced; color (palette) theme changes are now effective immediately, except on default.
  • Old deprecated Qt4 build support is no more.
  • Recover audio and MIDI dedicated port connections when changing any of the Metronome, Player and/or Control option settings.
  • Fix MIDI track (and bus) bank/program reset to none.
  • Anti-glitch micro-fade-in is disabled on audio clips with zero offset.
  • Audio and MIDI file players also stopped on Transport / Panic command.
  • LV2 plug-in UI GTK2 and X11 in Qt5 host native support are now disabled on default configure.
  • Get rid of symlink duplicates on the default plugin search paths.
  • According to Debian policy and guidelines, the out-of process plugin scanner (qtractor_plugin_scan) is now installed to $LIBDIR/qtractor.
Test Plan

opened, played & saved some midi files

Diff Detail

Repository
R2765 qtractor
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
Alexander88207 created this revision.Jan 3 2019, 9:18 PM
Alexander88207 requested review of this revision.Jan 3 2019, 9:18 PM
Alexander88207 edited the test plan for this revision. (Show Details)Jan 3 2019, 9:19 PM

@Jacalz Do you also like to test it?

Jacalz added a comment.EditedJan 4 2019, 10:55 AM

It is alright, I trust you have tested it perfectly fine yourself, but thanks for asking ๐Ÿ™‚ @Alexander8872

A did a little review on this though:

  • Update license to GPL-2.0-or-later
Jacalz edited the summary of this revision. (Show Details)EditedJan 4 2019, 11:15 AM

I fixed a little typo in your summary for you, from a '_' to '-' ๐Ÿ˜‰

Thanks, that's kind of you. ๐Ÿ‘

JoshStrobl requested changes to this revision.Jan 4 2019, 4:25 PM
JoshStrobl added a subscriber: JoshStrobl.
JoshStrobl added inline comments.
package.yml
6

You need to update the license.

This revision now requires changes to proceed.Jan 4 2019, 4:25 PM
  • Updated the license to GPL-2.0-or-later
DataDrake requested changes to this revision.Jan 7 2019, 12:27 PM
DataDrake added a subscriber: DataDrake.
DataDrake added inline comments.
package.yml
2โ€“3

Why did this go from 4 to 6?

This revision now requires changes to proceed.Jan 7 2019, 12:27 PM
Alexander88207 marked an inline comment as done.

Fixed release number

Alexander88207 marked an inline comment as done.
  • and again
DataDrake accepted this revision.Jan 8 2019, 4:07 AM

LGTM. Thanks!

This revision was not accepted when it landed; it landed in state Needs Review.Jan 8 2019, 4:09 AM
Closed by commit R2765:1e3b0c0f55a5: Update qtractor to 0.9.3 (authored by Alexander88207, committed by DataDrake). ยท Explain Why
This revision was automatically updated to reflect the committed changes.