Page MenuHomeSolus

Update qomui to 0.81
AbandonedPublic

Authored by davidjharder on Jan 3 2019, 12:34 AM.

Details

Summary

First attempt at updating this package. Need some help understanding why my simple patch does not resolve the issue mentioned below. Not suitable for committing yet.

Update qomui to 0.81. Resolves T7360.

Changelog:

0.80

  • [new] connection profiles
  • [new] support for custom scripts
  • [change] configurations for Airvpn are now downloaded directly
  • [change] removed minimize option if system tray not available
  • [change] download new Mullvad config/certificates
  • [change] added scroll areas to some tabs
  • [change] added options for profiles to tray menu
  • [change] window state now recognized correctly
  • [bugfix] improved stability and reliability of network detection
  • [bugfix] manually imported WireGuard servers don't connect
  • [bugfix] Qomui crashes when downloading Airvpn configs
  • [bugfix] fixed Mullvad & Windscribe configs

0.81

  • [change] option to restart qomui-service from gui if it
  • [change] added exceptions for all DBus
  • [change] detecting and closing simultaneously running instances
  • [bugfix] Airvpn auto-download fixed
Test Plan
  • start program from menu
  • add a provider, suggest mullvad as they provide free trial accounts.
  • add a profile
  • connect through a provider
  • try adding a bypass rule

Diff Detail

Repository
R4508 qomui
Branch
master
Lint
No Linters Available
Unit
No Unit Test Coverage

Event Timeline

davidjharder created this revision.Jan 3 2019, 12:34 AM
davidjharder requested review of this revision.Jan 3 2019, 12:34 AM

I do believe you are still missing the soft dependency cgroups/cgexec I can only seem to find cgmanger is the respiratory this dose not include cgexec

I do believe you are still missing the soft dependency cgroups/cgexec I can only seem to find cgmanger is the respiratory this dose not include cgexec

Right, other distros seem to use libcgroup, but that is not part of the solus repos. That is my second problem, my first is ensuring the patch to address T7360 works.

Bump to 0.81

fix release number

davidjharder retitled this revision from Update qomui to 0.80 to Update qomui to 0.81.Jan 6 2019, 9:20 PM
davidjharder edited the summary of this revision. (Show Details)
DataDrake accepted this revision.Jan 7 2019, 1:05 PM
DataDrake added a subscriber: DataDrake.

LGTM. Thanks!

This revision is now accepted and ready to land.Jan 7 2019, 1:05 PM

@DataDrake: I would not accept this yet. I haven't got one of the optional features working yet. See the summary. Sorry, but I was unsure of the correct way to flag a revision which needs work first.

DataDrake requested changes to this revision.Feb 14 2019, 12:58 AM
This revision now requires changes to proceed.Feb 14 2019, 12:58 AM
Jacalz added a subscriber: Jacalz.Mar 24 2019, 9:01 AM

Any news on this? @davidjharder

@davidjharder version 0.8.2 is available.
You can look at the patch I submitted (D5933) before I noticed you already submitted a patch for it. I have a few more dependencies, perhaps it will help solving your problem ?

DataDrake abandoned this revision.May 17 2019, 12:08 AM