Page MenuHomeSolus

Update python-astroid to 1.6.5
AbandonedPublic

Authored by EP01 on Jul 20 2018, 11:56 AM.

Details

Reviewers
DataDrake
debug
Group Reviewers
Triage Team
Summary

Updated 'python-astroid' to the latest Python2 compatible version 1.6.5.

Move Python 3 support to new package.

Full changelog available here.

Test Plan

Used to build 'pylint' sucessfully.
Installed with 'pylint' which is correctly linting Python files.

Diff Detail

Repository
R3709 python-astroid
Branch
master
Lint
No Linters Available
Unit
No Unit Test Coverage

Event Timeline

debug created this revision.Jul 20 2018, 11:56 AM
debug requested review of this revision.Jul 20 2018, 11:56 AM
debug edited the summary of this revision. (Show Details)Jul 20 2018, 12:02 PM
DataDrake requested changes to this revision.Jul 25 2018, 11:47 AM
DataDrake added a subscriber: DataDrake.
DataDrake added inline comments.
package.yml
20

Needs to be alphabetical

This revision now requires changes to proceed.Jul 25 2018, 11:47 AM
debug updated this revision to Diff 8389.Jul 25 2018, 12:02 PM

Sorted rundeps

EP01 updated this revision to Diff 8542.Aug 1 2018, 11:15 AM
EP01 added a subscriber: EP01.

Update to 1.6.5 instead

EP01 commandeered this revision.Aug 1 2018, 11:16 AM
EP01 retitled this revision from Update python-astroid to 2.0.1 to Update python-astroid to 1.6.5.
EP01 edited the summary of this revision. (Show Details)
EP01 edited the summary of this revision. (Show Details)
EP01 added a reviewer: debug.
EP01 added a comment.Aug 1 2018, 11:20 AM

Hey @debug, I'm moving the python3 support for this package to a new package, as per other packages. I figured I would just update this existing diff rather than creating a new one. Hope that's ok with you!

EP01 marked an inline comment as done.Aug 1 2018, 11:28 AM
DataDrake abandoned this revision.Aug 25 2018, 7:57 PM

Abandoning since it will be faster for me to fix the naming and you didn't know. Thanks for the leg work Ewan!