Page MenuHomeSolus

Updated pylint to 1.8.4
ClosedPublic

Authored by debug on May 7 2018, 8:45 PM.

Details

Summary

Updated pylint to the latest version 1.8.4.
Change log available here.

Test Plan

Installed in a virtual machine with the updated version of python-astroid and ran with Python files with/without errors.
All tests ran as expected.

Diff Detail

Repository
R3714 pylint
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

debug created this revision.May 7 2018, 8:45 PM
debug requested review of this revision.May 7 2018, 8:45 PM
debug added a comment.May 8 2018, 1:05 AM

After looking back at this differential I believe I misunderstood when to use 'Depends'. Updating 'pylint' does not *require* updating 'python-astroid' however as it states of the GitHub page the later the version of 'python-astroid' the better. I'll leave the 'Depends' in the differential for now unless instructed otherwise.

kyrios123 added inline comments.
package.yml
5–6

General comment, when you update a package, please make sure to adapt the license code to SPDX 3.x.
The impacted licenses are mainly the AGPL, GPL, GDFL, LGPL that must be suffixed with -only or -or-later.

debug added a comment.May 8 2018, 9:43 AM

Okay. I will go through my current open patches and update them where necessary.

debug updated this revision to Diff 7081.May 8 2018, 10:21 AM

Updated license

debug updated this revision to Diff 7082.May 8 2018, 10:26 AM

Forgot to update license in pspec_x86_64.xml

debug updated this revision to Diff 7087.May 8 2018, 3:14 PM
debug marked an inline comment as done.
debug edited the summary of this revision. (Show Details)

Removed the depends on D2885.

DataDrake accepted this revision.Jun 10 2018, 4:46 PM
DataDrake added a subscriber: DataDrake.

LGTM. Thanks!

This revision is now accepted and ready to land.Jun 10 2018, 4:46 PM
This revision was automatically updated to reflect the committed changes.