Page MenuHomeSolus

Initial commit for ripgrep-all
ClosedPublic

Authored by biqqles on Aug 22 2022, 10:16 PM.

Details

Summary

Packages ripgrep-all to close T10353.

Test Plan

Use rga <pattern> <files> to test.

Grepping pdf files requires poppler, which is of course installed by default. Searching most other document formats (e.g. docx) requires pandoc. I think it makes sense to not list these adapters as rundeps as the error message is abundantly clear. Notably pandoc has a vast number of dependencies.

Diff Detail

Repository
R5584 ripgrep-all
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

biqqles created this revision.Aug 22 2022, 10:16 PM
biqqles requested review of this revision.Aug 22 2022, 10:16 PM
algent requested changes to this revision.Aug 27 2022, 6:54 PM
algent added a subscriber: algent.

Please add a MAINTAINERS.md file.

This revision now requires changes to proceed.Aug 27 2022, 6:54 PM
biqqles updated this revision to Diff 33065.Aug 27 2022, 8:13 PM

Add MAINTAINERS.md

biqqles updated this revision to Diff 33067.Aug 27 2022, 8:18 PM

Add back other files, sigh

algent requested changes to this revision.Aug 27 2022, 9:27 PM

One more little thing.
The license appears to be AGPL-3.0-or-later

package.yml
8

AGPL-3.0-or-later

This revision now requires changes to proceed.Aug 27 2022, 9:27 PM
biqqles updated this revision to Diff 33085.Aug 28 2022, 11:53 AM

Specify correct license

algent requested changes to this revision.Aug 28 2022, 11:54 AM
algent added inline comments.
pspec_x86_64.xml
10

Fix the license here too.

This revision now requires changes to proceed.Aug 28 2022, 11:54 AM
algent accepted this revision.Aug 28 2022, 12:00 PM

LGTM, thanks!

This revision is now accepted and ready to land.Aug 28 2022, 12:00 PM
This revision was automatically updated to reflect the committed changes.