Page MenuHomeSolus

Update python-apsw to 3.34.0
ClosedPublic

Authored by algent on Aug 27 2021, 4:32 PM.

Details

Summary

Full changelog here

Packager notes:

  • Update to 3.34.0 to match sqlite3 version. New version requires updating sqlite3 too.
  • Enable --enable=load_extension for calibre. Fixes the calibre database crash in newer versions.
  • Add a homepage.
  • Enable build tests.

Signed-off-by: Algent Albrahimi <algent@protonmail.com>

Test Plan
  • Update calibre against this package.
  • Rebuild and successfully pass build tests for python-peewee.

Diff Detail

Repository
R2548 python-apsw
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

algent created this revision.Aug 27 2021, 4:32 PM
algent requested review of this revision.Aug 27 2021, 4:32 PM
algent edited the summary of this revision. (Show Details)Aug 27 2021, 4:33 PM
algent planned changes to this revision.Aug 27 2021, 4:42 PM
algent requested review of this revision.Aug 27 2021, 10:41 PM

Works fine with currend and old version of calibre.

JoshStrobl accepted this revision.Aug 31 2021, 11:22 AM
JoshStrobl added a subscriber: JoshStrobl.

LGTM, thanks!

This revision is now accepted and ready to land.Aug 31 2021, 11:22 AM
This revision was automatically updated to reflect the committed changes.