Page MenuHomeSolus

Update RStudio to 1.4.1717
ClosedPublic

Authored by kevindkeogh on Jul 22 2021, 7:33 PM.

Details

Summary

Changelog available here

Test Plan

Started GUI and checked version
Ran install.packages("tidyverse") in console
Tested a few computations in the console
Tested a few sample programs and confirmed output

Diff Detail

Repository
R2826 rstudio
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

kevindkeogh created this revision.Jul 22 2021, 7:33 PM
kevindkeogh requested review of this revision.Jul 22 2021, 7:33 PM
JoshStrobl accepted this revision.Jul 23 2021, 10:10 AM
JoshStrobl edited the summary of this revision. (Show Details)
JoshStrobl added a subscriber: JoshStrobl.

LGTM, thanks!

This revision is now accepted and ready to land.Jul 23 2021, 10:11 AM
This revision was automatically updated to reflect the committed changes.

Your build failed. Please provide a follow-up patch that corrects the error(s): https://build.getsol.us//logs/rstudio-1.4.1717-20.log.gz

N1X3L added a subscriber: N1X3L.Jul 24 2021, 3:00 AM

Unfortunately, I think there is still a problem. The upgrade process is prematurely terminating with the alert message:

Installing rstudio, version 1.4.1717, release 21
Upgrading to new upstream version
Extracting the files of rstudio
 [✓] Syncing filesystems                                                success
System error. Program terminated.
[Errno 18] Invalid cross-device link

journalctl doesn't appear to log anything of note — simply that the session opened, then closed. Please advise when possible.

@N1X3L I would appreciate if you could file a separate issue so it can be assigned to them and tracked separately.

N1X3L added a comment.Jul 27 2021, 6:06 AM

@JoshStrobl I'll forgo filing a separate issue at this time, because the RStudio in Unstable seems to be working. So come Friday sync, I think everything should be functioning as expected. So sorry for the notification clutter, and misplaced filing though! Thank you!

JoshStrobl added a comment.EditedJul 27 2021, 9:51 AM

@JoshStrobl I'll forgo filing a separate issue at this time, because the RStudio in Unstable seems to be working. So come Friday sync, I think everything should be functioning as expected. So sorry for the notification clutter, and misplaced filing though! Thank you!

The version that is in the unstable repo is identical to shannon. Both are on rel 21.

N1X3L added a comment.Jul 30 2021, 6:07 PM

The version that is in the unstable repo is identical to shannon. Both are on rel 21.

Right you are! Once I got back in the office and could use my other machine (which had the same problem), I tried uninstalling and reinstalling again. But there I used the package from Shannon, not Unstable. So it was just the uninstall/reinstall that corrected my problem; installing it from the Unstable repo had nothing to do with it. Thank you for helping me better understand the solution!