Page MenuHomeSolus

Update python-qtwebengine to 5.15.4 and build against new python-sip
ClosedPublic

Authored by algent on Jul 10 2021, 7:25 PM.

Details

Summary

Changelog:

  • Packaging bug fixes.
  • Wheels now assume that the corresponding Qt libraries are in an external wheel rather than being bundled.

Depends on D11434 D11441

Signed-off-by: Algent Albrahimi <algent@protonmail.com>

Test Plan
  • Update calibre against this package.
  • Run spyder3, sigil, qutebrowser and anki.

Diff Detail

Repository
R4831 python-qtwebengine
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

algent created this revision.Jul 10 2021, 7:25 PM
algent requested review of this revision.Jul 10 2021, 7:25 PM
algent updated this revision to Diff 27682.Jul 10 2021, 9:16 PM

sort builddeps

JoshStrobl added inline comments.
package.yml
28

Does -C build not work in this case?

algent updated this revision to Diff 27708.Jul 12 2021, 3:06 PM

Improve install step in package.yml file

algent marked an inline comment as done.Jul 12 2021, 3:06 PM
JoshStrobl accepted this revision.Jul 16 2021, 10:19 AM

LGTM, thanks!

This revision is now accepted and ready to land.Jul 16 2021, 10:19 AM